package/mariadb: remove mariadb_config from target
authorRyan Coe <bluemrp9@gmail.com>
Tue, 4 Feb 2020 01:21:54 +0000 (17:21 -0800)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 4 Feb 2020 13:57:20 +0000 (14:57 +0100)
We already remove mysql_config from the target since it's only useful in
staging. The same is true for mariadb_config. Thus, we remove it from the
target as well.

Signed-off-by: Ryan Coe <bluemrp9@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mariadb/mariadb.mk

index f76a974d65b6b518d829bedfad983c8d9bed6711..4e7d693aee95b584fc495851530c0c790ddd0694 100644 (file)
@@ -123,11 +123,12 @@ define MARIADB_INSTALL_INIT_SYSTEMD
 endef
 endif
 
-# We don't need mysql_config on the target as it's only useful in staging
-# We also don't need the test suite on the target
+# We don't need mysql_config or mariadb_config on the target as it's
+# only useful in staging. We also don't need the test suite on the target.
 define MARIADB_POST_INSTALL
        mkdir -p $(TARGET_DIR)/var/lib/mysql
        $(RM) $(TARGET_DIR)/usr/bin/mysql_config
+       $(RM) $(TARGET_DIR)/usr/bin/mariadb_config
        $(RM) -r $(TARGET_DIR)/usr/share/mysql/test
 endef