Makefile: make GNU_HOST_NAME a simply expanded variable (:=)
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 6 May 2010 18:53:25 +0000 (20:53 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 6 May 2010 18:56:25 +0000 (20:56 +0200)
GNU_HOST_NAME is referred more than 100 times in the tree, used 5
times during startup, and is relatively expensive to run - so make
it a simple expanded variable (:=) rather than recursively expanded
one (=).

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 5da21d888086284a4316b1f4a9a3f10bfeb9c178..a4bf4b570e9fcd73bcfca7e60d3d485d0b9f825c 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -153,7 +153,7 @@ cc-option=$(shell if $(TARGET_CC) $(TARGET_CFLAGS) $(1) -S -o /dev/null -xc /dev
 unexport CROSS_COMPILE
 unexport ARCH
 
-GNU_HOST_NAME=$(shell package/gnuconfig/config.guess)
+GNU_HOST_NAME:=$(shell package/gnuconfig/config.guess)
 
 #############################################################
 #