samba: fix linking of smbd with avahi support
authorSven Neumann <s.neumann@raumfeld.com>
Tue, 13 Sep 2011 08:42:08 +0000 (10:42 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 13 Sep 2011 19:32:14 +0000 (21:32 +0200)
Expliticly link with -lpthread if smbd is compiled with
avahi support. Otherwise the binary will fail to run.

Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/samba/samba-fix-smbd-libs-avahi.patch [new file with mode: 0644]

diff --git a/package/samba/samba-fix-smbd-libs-avahi.patch b/package/samba/samba-fix-smbd-libs-avahi.patch
new file mode 100644 (file)
index 0000000..d6423de
--- /dev/null
@@ -0,0 +1,15 @@
+Expliticly link with -lpthread if smbd is compiled with
+avahi support. Otherwise the binary will fail to run.
+
+Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
+--- samba-3.5.6-orig/source3/Makefile.in       2010-10-07 18:41:16.000000000 +0200
++++ samba-3.5.6/source3/Makefile.in    2010-10-27 14:52:40.000000000 +0200
+@@ -1552,7 +1552,7 @@
+               $(KRB5LIBS) $(DYNEXP) $(PRINT_LIBS) $(AUTH_LIBS) \
+               $(ACL_LIBS) $(PASSDB_LIBS) $(LIBS) $(DNSSD_LIBS) $(AVAHI_LIBS) \
+               $(POPT_LIBS) @SMBD_LIBS@ $(LIBTALLOC_LIBS) $(LIBTDB_LIBS) \
+-              $(LIBWBCLIENT_LIBS) $(ZLIB_LIBS)
++              $(LIBWBCLIENT_LIBS) $(ZLIB_LIBS) $(PTHREAD_LDFLAGS)
+ bin/nmbd@EXEEXT@: $(BINARY_PREREQS) $(NMBD_OBJ) @BUILD_POPT@ $(LIBTALLOC) $(LIBTDB) $(LIBWBCLIENT)
+       @echo Linking $@