Fix ccache handling
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Apr 2011 16:44:36 +0000 (18:44 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 2 Apr 2011 20:34:09 +0000 (22:34 +0200)
When ccache support is enabled and 'make silentoldconfig' is being
started from the following rule:

$(BUILD_DIR)/buildroot-config/auto.conf: $(CONFIG_DIR)/.config
$(MAKE) $(EXTRAMAKEARGS) HOSTCC="$(HOSTCC_NOCCACHE)" HOSTCXX="$(HOSTCXX_NOCCACHE)" silentoldconfig

then, the Makefile in package/config inherits from HOSTCC/HOSTCXX
values with the ccache prefix. However, if we start from a cleaned
build (after make clean), ccache is not compiled yet, so things break.

To solve this, we pass a noccache variant of HOSTCC/HOSTCXX down to
the package/config Makefile.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 9aa7399f1daaf2085b89cdce5a57f5b8aeacdc07..2e698cc18cd0a2ee45252c4840dae78c79b1c60d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -367,7 +367,7 @@ dirs: $(DL_DIR) $(TOOLCHAIN_DIR) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) \
 $(BASE_TARGETS): dirs $(O)/toolchainfile.cmake
 
 $(BUILD_DIR)/buildroot-config/auto.conf: $(CONFIG_DIR)/.config
-       $(MAKE) $(EXTRAMAKEARGS) silentoldconfig
+       $(MAKE) $(EXTRAMAKEARGS) HOSTCC="$(HOSTCC_NOCCACHE)" HOSTCXX="$(HOSTCXX_NOCCACHE)" silentoldconfig
 
 prepare: $(BUILD_DIR)/buildroot-config/auto.conf