vlc: needs dependency on host-lua if Lua is selected
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Sun, 16 Feb 2014 18:32:42 +0000 (19:32 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 16 Feb 2014 20:02:34 +0000 (21:02 +0100)
If Lua support is requested in VLC, its configure script tries to find the
luac byte compiler, which fails if host-lua is not yet built.

This can be easily reproduced by setting a minimal config with vlc and Lua
enabled, and running: 'make clean toolchain vlc'. Final output is:

checking for LUA... no
configure: WARNING: Package lua5.2 was not found in the pkg-config search path.
Perhaps you should add the directory containing `lua5.2.pc'
to the PKG_CONFIG_PATH environment variable
No package 'lua5.2' found, trying lua 5.1 instead
checking for LUA... no
configure: WARNING: Package lua5.1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `lua5.1.pc'
to the PKG_CONFIG_PATH environment variable
No package 'lua5.1' found, trying lua >= 5.1 instead
checking for LUA... yes
checking for luac... no
configure: error: Could not find the LUA byte compiler.
make: *** [<buildroot>/output/build/vlc-2.1.2/.stamp_configured] Error 1

Fix this problem by setting host-lua as a dependency to vlc.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/vlc/vlc.mk

index f235ff81176316158a2b6df764f13935c51813c0..61695147aee4dfc304aa75cdd1e1e70d602ea21e 100644 (file)
@@ -226,7 +226,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_LUA),y)
 VLC_CONF_OPT += --enable-lua
-VLC_DEPENDENCIES += lua
+VLC_DEPENDENCIES += lua host-lua
 else
 VLC_CONF_OPT += --disable-lua
 endif