mtdev: new package
authorStephan Hoffmann <sho@relinux.de>
Wed, 29 Aug 2012 09:01:06 +0000 (11:01 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 30 Aug 2012 02:38:27 +0000 (04:38 +0200)
The mtdev is a stand-alone library which transforms all variants
of kernel multitouch events to the slotted type B protocol.

http://bitmath.org/code/mtdev/

Signed-off-by: Stephan Hoffmann <sho@relinux.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/mtdev/Config.in [new file with mode: 0644]
package/mtdev/mtdev.mk [new file with mode: 0644]

index d1b214cf5091fa51db2f438ed192b63d42940a60..f0fe0a68146aa887bdf3840fe5fc6bf38bd837a8 100644 (file)
@@ -387,6 +387,7 @@ source "package/libnfc-llcp/Config.in"
 source "package/libusb/Config.in"
 source "package/libusb-compat/Config.in"
 source "package/libv4l/Config.in"
+source "package/mtdev/Config.in"
 endmenu
 
 menu "Javascript"
diff --git a/package/mtdev/Config.in b/package/mtdev/Config.in
new file mode 100644 (file)
index 0000000..3419903
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_MTDEV
+       bool "mtdev"
+       help
+         The mtdev is a stand-alone library which transforms all
+         variants of kernel MT events to the slotted type B protocol.
+
+         http://bitmath.org/code/mtdev/
+
diff --git a/package/mtdev/mtdev.mk b/package/mtdev/mtdev.mk
new file mode 100644 (file)
index 0000000..09f76f2
--- /dev/null
@@ -0,0 +1,14 @@
+#############################################################
+#
+# mtdev
+#
+#############################################################
+MTDEV_VERSION = 1.1.3
+MTDEV_SOURCE = mtdev-$(MTDEV_VERSION).tar.bz2
+MTDEV_SITE = http://bitmath.org/code/mtdev/
+
+MTDEV_LICENSE = MIT
+MTDEV_LICENSE_FILES = COPYING
+MTDEV_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))