toolchain-external: allow specifying extra external libraries
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>
Sun, 2 Oct 2011 19:20:10 +0000 (21:20 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 9 Oct 2011 19:30:44 +0000 (21:30 +0200)
Custom toolchains may provide extra libraries that need to be copied to the
target. This patch adds a configuration option for this.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index ff7e8db97ef1821da1fde53261b29887fe8414e6..b6fa9bd267f62652732acd71835d5f2a3ea8e8f2 100644 (file)
@@ -322,6 +322,14 @@ config BR2_TOOLCHAIN_EXTERNAL_CXX
          support. If you don't know, leave the default value,
          Buildroot will tell you if it's correct or not.
 
+config BR2_TOOLCHAIN_EXTRA_EXTERNAL_LIBS
+       string "Extra toolchain libraries to be copied to target"
+       help
+         If your external toolchain provides extra libraries that
+         need to be copied to the target filesystem, enter them
+         here, separated by spaces. They will be copied to the
+         target's /lib directory.
+
 endif # BR2_TOOLCHAIN_EXTERNAL_CUSTOM
 
 endif # BR2_TOOLCHAIN_EXTERNAL
index b9d932f685669ee78e4a5a3997501b7e4255d823..bac39cf3a98dd40e033c4a17aa1550a18e6ff199 100644 (file)
@@ -51,6 +51,7 @@
 #  of Buildroot is handled identical for the 2 toolchain types.
 
 LIB_EXTERNAL_LIBS=ld*.so libc.so libcrypt.so libdl.so libgcc_s.so libm.so libnsl.so libresolv.so librt.so libutil.so
+LIB_EXTERNAL_LIBS+=$(call qstrip,$(BR2_TOOLCHAIN_EXTRA_EXTERNAL_LIBS))
 ifeq ($(BR2_TOOLCHAIN_EXTERNAL_GLIBC),y)
 LIB_EXTERNAL_LIBS+=libnss_files.so libnss_dns.so
 endif