systemd: fix -Dlibidn2 option when libidn2 is not available
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 23 May 2018 05:59:22 +0000 (07:59 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 23 May 2018 06:01:16 +0000 (08:01 +0200)
Commit 4ded5d6af4f0198036183f00de190569d7578bc3 ("systemd: add
optional dependency on libidn2") contained a mistake: -Dlibidn2=true
was passed even when neither libidn nor libidn2 are
available. Obviously it should be -Dlibidn2=false.

Reported-by: Arnout Vandecappelle <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/systemd/systemd.mk

index 1e4b257731999f56fec5fe577ed74c3c68ae9fc4..8f7a9fa93c6c521eb41aefaba0bb2a25e9b6bd77 100644 (file)
@@ -83,7 +83,7 @@ else ifeq ($(BR2_PACKAGE_LIBIDN),y)
 SYSTEMD_DEPENDENCIES += libidn
 SYSTEMD_CONF_OPTS += -Dlibidn=true -Dlibidn2=false
 else
-SYSTEMD_CONF_OPTS += -Dlibidn=false -Dlibidn2=true
+SYSTEMD_CONF_OPTS += -Dlibidn=false -Dlibidn2=false
 endif
 
 ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)