Convert busybox to the device declaration method
authorMaxime Ripard <maxime.ripard@free-electrons.com>
Wed, 11 Jan 2012 17:53:39 +0000 (18:53 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 1 Feb 2012 22:04:49 +0000 (23:04 +0100)
Busybox used to declare and create files even if the package was not
enabled through the device table. Remove the entries for busybox in the
device table and move them to the package declaration.

Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
Acked-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/busybox/busybox.mk
target/generic/device_table.txt

index d18b6d0b13b22861763acc8bcb1ae67caec24773..59448d5a2f6d05877fa3f21ec8c178283630db8a 100644 (file)
@@ -28,6 +28,11 @@ ifndef BUSYBOX_CONFIG_FILE
        BUSYBOX_CONFIG_FILE = $(call qstrip,$(BR2_PACKAGE_BUSYBOX_CONFIG))
 endif
 
+define BUSYBOX_PERMISSIONS
+/bin/busybox                    f 4755 0 0 - - - - -
+/usr/share/udhcpc/default.script f 755  0 0 - - - - -
+endef
+
 # If mdev will be used for device creation enable it and copy S10mdev to /etc/init.d
 ifeq ($(BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV),y)
 define BUSYBOX_INSTALL_MDEV_SCRIPT
index 12f35b2755d1e4e69e1a0aa1da3519ecb0cb5bca..d3e394ba99b356adeab69fc469b85dc5139d9559 100644 (file)
 /tmp                                   d       1777    0       0       -       -       -       -       -
 /etc                                   d       755     0       0       -       -       -       -       -
 /home/default                          d       2755    1000    1000    -       -       -       -       -
-/bin/busybox                           f       4755    0       0       -       -       -       -       -
 /etc/shadow                            f       600     0       0       -       -       -       -       -
 /etc/passwd                            f       644     0       0       -       -       -       -       -
 /etc/network/if-up.d                   d       755     0       0       -       -       -       -       -
 /etc/network/if-pre-up.d               d       755     0       0       -       -       -       -       -
 /etc/network/if-down.d                 d       755     0       0       -       -       -       -       -
 /etc/network/if-post-down.d            d       755     0       0       -       -       -       -       -
-/usr/share/udhcpc/default.script       f       755     0       0       -       -       -       -       -
 # uncomment this to allow starting x as non-root
 #/usr/X11R6/bin/Xfbdev                 f       4755    0       0       -       -       -       -       -