support/scripts/mkmakefile: make wrapper silent by default
authorSerj Kalichev <serj.kalichev@gmail.com>
Fri, 2 Nov 2018 11:29:33 +0000 (14:29 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 2 Nov 2018 20:23:02 +0000 (21:23 +0100)
Suppose we use Makefile wrapper and build some project out of
buildroot tree (O=...). A command like "make
busybox-all-external-deps" will output the string "uname 022 && make
..." to stdout before the usefull information. It pollutes stdout. At
the same time if we use the same command in the buildroot source-tree
then we don't get the additional output. This patch makes wrapper
silent by default. People who prefer to see more verbose output can
use V=1.

Signed-off-by: Serj Kalichev <serj.kalichev@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
support/scripts/mkmakefile

index 37162a3173acc6beb31dada85114613003923e3e..c7569f2ca57a4e8f1da2d22cc0008d070131b734 100755 (executable)
@@ -20,6 +20,13 @@ echo "  GEN     $2/Makefile"
 cat << EOF > $2/Makefile
 # Automatically generated by $0: don't edit
 
+ifeq ("\$(origin V)", "command line")
+VERBOSE := \$(V)
+endif
+ifneq (\$(VERBOSE),1)
+Q := @
+endif
+
 lastword = \$(word \$(words \$(1)),\$(1))
 makedir := \$(dir \$(call lastword,\$(MAKEFILE_LIST)))
 
@@ -33,7 +40,7 @@ MAKEFLAGS += --no-print-directory
 all    := \$(filter-out Makefile,\$(MAKECMDGOALS))
 
 _all:
-       umask 0022 && \$(MAKE) \$(MAKEARGS) \$(all)
+       \$(Q)umask 0022 && \$(MAKE) \$(MAKEARGS) \$(all)
 
 Makefile:;