package/at: convert local patches to git format
authorGiulio Benetti <giulio.benetti@benettiengineering.com>
Fri, 23 Jul 2021 20:08:36 +0000 (22:08 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 25 Jul 2021 13:03:46 +0000 (15:03 +0200)
Convert local patches to git format. Note that some of them change name
because of use of 'git format-patch'.

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/at/0001-Makefile.in-replace-IROOT-by-DESTDIR.patch
package/at/0002-Makefile.in-fix-make-install-for-non-root-don-t-stri.patch [new file with mode: 0644]
package/at/0002-Makefile.in-make-install-fix.patch [deleted file]
package/at/0003-getloadavg-fix-getloadavg.c-compilation-revert-to-3..patch [new file with mode: 0644]
package/at/0003-getloadavg.c-fix.patch [deleted file]

index 856b6c8d08f019c8c68f534dc874b995d4b6f631..f595bce9cf8d204745777b59930c26e983cea7d4 100644 (file)
@@ -1,25 +1,26 @@
-From 195d30e2e01fe2f91ed3bdaeec3982aa66b309dd Mon Sep 17 00:00:00 2001
+From d2bdcff4748f4c1961118b9467bab302b403ef9f Mon Sep 17 00:00:00 2001
 From: Marc Kleine-Budde <mkl@pengutronix.de>
 Date: Tue, 1 Dec 2009 20:57:45 +0100
-Subject: [PATCH 5/5] Makefile.in: replace IROOT by DESTDIR
+Subject: [PATCH] Makefile.in: replace IROOT by DESTDIR
 
 This patch replaces IROOT by DESTDIR, which is the autotools standard
 variable. For backwards compatibilty IROOT overwrites the DESTDIR.
 
-[Vincent: tweak the patch for the new version]
-
 Signed-off-by: Marc Kleine-Budde <mkl@pengutronix.de>
 Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
+[Vincent: tweak the patch for the new version]
+Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
+[Giulio: convert patch to git format]
 ---
- Makefile.in | 68 ++++++++++++++++++++++++++++++++-----------------------------
+ Makefile.in | 68 ++++++++++++++++++++++++++++-------------------------
  1 file changed, 36 insertions(+), 32 deletions(-)
 
 diff --git a/Makefile.in b/Makefile.in
-index 06544f9..1f699d9 100644
+index 4c11913..61e7b1d 100644
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -17,6 +17,10 @@ atdocdir    = $(docdir)/at
etcdir                = @ETCDIR@
+@@ -18,6 +18,10 @@ etcdir              = @ETCDIR@
atjobdir      = @ATJBD@
  systemdsystemunitdir = @systemdsystemunitdir@
  
 +ifdef IROOT
@@ -29,7 +30,7 @@ index 06544f9..1f699d9 100644
  DAEMON_USERNAME       = @DAEMON_USERNAME@
  DAEMON_GROUPNAME= @DAEMON_GROUPNAME@
  LOADAVG_MX    = @LOADAVG_MX@
-@@ -91,41 +95,41 @@ atrun: atrun.in
+@@ -93,41 +97,41 @@ atrun: atrun.in
        $(CC) -c $(CFLAGS) $(DEFS) $*.c
  
  install: all
@@ -104,5 +105,5 @@ index 06544f9..1f699d9 100644
  
  dist: checkin $(DIST) $(LIST) Filelist.asc
 -- 
-2.4.10
+2.25.1
 
diff --git a/package/at/0002-Makefile.in-fix-make-install-for-non-root-don-t-stri.patch b/package/at/0002-Makefile.in-fix-make-install-for-non-root-don-t-stri.patch
new file mode 100644 (file)
index 0000000..866175d
--- /dev/null
@@ -0,0 +1,87 @@
+From 2dd7c3c5b590a3115568175acc888f8e36919d71 Mon Sep 17 00:00:00 2001
+From: Peter Korsgaard <jacmet@sunsite.dk>
+Date: Fri, 23 Jul 2021 16:47:56 +0200
+Subject: [PATCH] Makefile.in: fix make install for non-root, don't strip
+
+Buildroot will ensure all files are owned by root and stripped anyway
+(if needed) before the rootfs is created.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
+[Vincent: tweak the patch for the new version]
+Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
+[Giulio: convert patch to git format]
+---
+ Makefile.in | 43 +++++++++++++++++++++----------------------
+ 1 file changed, 21 insertions(+), 22 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 61e7b1d..9f89b1f 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -97,41 +97,40 @@ atrun: atrun.in
+       $(CC) -c $(CFLAGS) $(DEFS) $*.c
+ install: all
+-      $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(etcdir)
+-      $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(bindir)
+-      $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(sbindir)
+-      $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(docdir)
+-      $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(atdocdir)
+-      $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 755 -d $(DESTDIR)$(ATSPOOL_DIR) $(DESTDIR)$(ATJOB_DIR)
++      $(INSTALL) -m 755 -d $(DESTDIR)$(etcdir)
++      $(INSTALL) -m 755 -d $(DESTDIR)$(bindir)
++      $(INSTALL) -m 755 -d $(DESTDIR)$(sbindir)
++      $(INSTALL) -m 755 -d $(DESTDIR)$(docdir)
++      $(INSTALL) -m 755 -d $(DESTDIR)$(atdocdir)
++      $(INSTALL) -m 755 -d $(DESTDIR)$(ATSPOOL_DIR) $(DESTDIR)$(ATJOB_DIR)
+       chmod 1770 $(DESTDIR)$(ATSPOOL_DIR) $(DESTDIR)$(ATJOB_DIR)
+       touch $(DESTDIR)$(LFILE)
+       chmod 600 $(DESTDIR)$(LFILE)
+-      chown $(DAEMON_USERNAME):$(DAEMON_GROUPNAME) $(DESTDIR)$(LFILE)
+-      test -f $(DESTDIR)$(etcdir)/at.allow || test -f $(DESTDIR)$(etcdir)/at.deny || $(INSTALL) -o root -g $(DAEMON_GROUPNAME) -m 640 at.deny $(DESTDIR)$(etcdir)/
+-      $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 6755 at $(DESTDIR)$(bindir)
++      test -f $(DESTDIR)$(etcdir)/at.allow || test -f $(DESTDIR)$(etcdir)/at.deny || $(INSTALL) -m 640 at.deny $(DESTDIR)$(etcdir)/
++      $(INSTALL) -m 6755 at $(DESTDIR)$(bindir)
+       $(LN_S) -f at $(DESTDIR)$(bindir)/atq
+       $(LN_S) -f at $(DESTDIR)$(bindir)/atrm
+-      $(INSTALL) -g root -o root -m 755 batch $(DESTDIR)$(bindir)
+-      $(INSTALL) -d -o root -g root -m 755 $(DESTDIR)$(man1dir)
+-      $(INSTALL) -d -o root -g root -m 755 $(DESTDIR)$(man5dir)
+-      $(INSTALL) -d -o root -g root -m 755 $(DESTDIR)$(man8dir)
+-      $(INSTALL) -g root -o root -m 755 atd $(DESTDIR)$(sbindir)
+-      $(INSTALL) -g root -o root -m 755 atrun $(DESTDIR)$(sbindir)
+-      $(INSTALL) -g root -o root -m 644 at.1 $(DESTDIR)$(man1dir)/
++      $(INSTALL) -m 755 batch $(DESTDIR)$(bindir)
++      $(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)
++      $(INSTALL) -d -m 755 $(DESTDIR)$(man5dir)
++      $(INSTALL) -d -m 755 $(DESTDIR)$(man8dir)
++      $(INSTALL) -m 755 atd $(DESTDIR)$(sbindir)
++      $(INSTALL) -m 755 atrun $(DESTDIR)$(sbindir)
++      $(INSTALL) -m 644 at.1 $(DESTDIR)$(man1dir)/
+       cd $(DESTDIR)$(man1dir) && $(LN_S) -f at.1 atq.1 && $(LN_S) -f at.1 batch.1 && $(LN_S) -f at.1 atrm.1
+-      $(INSTALL) -g root -o root -m 644 atd.8 $(DESTDIR)$(man8dir)/
++      $(INSTALL) -m 644 atd.8 $(DESTDIR)$(man8dir)/
+       sed "s,\$${exec_prefix},$(exec_prefix),g" <atrun.8>tmpman
+-      $(INSTALL) -g root -o root -m 644 tmpman $(DESTDIR)$(man8dir)/atrun.8
++      $(INSTALL) -m 644 tmpman $(DESTDIR)$(man8dir)/atrun.8
+       rm -f tmpman
+-      $(INSTALL) -g root -o root -m 644 at.allow.5 $(DESTDIR)$(man5dir)/
++      $(INSTALL) -m 644 at.allow.5 $(DESTDIR)$(man5dir)/
+       cd $(DESTDIR)$(man5dir) && $(LN_S) -f at.allow.5 at.deny.5
+-      $(INSTALL) -g root -o root -m 644 $(DOCS) $(DESTDIR)$(atdocdir)
++      $(INSTALL) -m 644 $(DOCS) $(DESTDIR)$(atdocdir)
+       rm -f $(DESTDIR)$(mandir)/cat1/at.1* $(DESTDIR)$(mandir)/cat1/batch.1* \
+               $(DESTDIR)$(mandir)/cat1/atq.1*
+       rm -f $(DESTDIR)$(mandir)/cat1/atd.8*
+       if test x"$(systemdsystemunitdir)" != xno; then \
+-              $(INSTALL) -o root -g root -m 755 -d $(DESTDIR)$(systemdsystemunitdir); \
+-              $(INSTALL) -o root -g root -m 644 atd.service $(DESTDIR)$(systemdsystemunitdir); \
++              $(INSTALL) -m 755 -d $(DESTDIR)$(systemdsystemunitdir); \
++              $(INSTALL) -m 644 atd.service $(DESTDIR)$(systemdsystemunitdir); \
+       fi
+ dist: checkin $(DIST) $(LIST) Filelist.asc
+-- 
+2.25.1
+
diff --git a/package/at/0002-Makefile.in-make-install-fix.patch b/package/at/0002-Makefile.in-make-install-fix.patch
deleted file mode 100644 (file)
index 831ea1a..0000000
+++ /dev/null
@@ -1,83 +0,0 @@
-[PATCH]: Makefile.in: fix make install for non-root, don't strip
-
-Buildroot will ensure all files are owned by root and stripped anyway
-(if needed) before the rootfs is created.
-
-[Vincent: tweak the patch for the new version]
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
----
- Makefile.in | 43 +++++++++++++++++++++----------------------
- 1 file changed, 21 insertions(+), 22 deletions(-)
-
-diff --git a/Makefile.in b/Makefile.in
-index 1f699d9..f313f9b 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -95,41 +95,40 @@ atrun: atrun.in
-       $(CC) -c $(CFLAGS) $(DEFS) $*.c
- install: all
--      $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(etcdir)
--      $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(bindir)
--      $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(sbindir)
--      $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(docdir)
--      $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(atdocdir)
--      $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 755 -d $(DESTDIR)$(ATSPOOL_DIR) $(DESTDIR)$(ATJOB_DIR)
-+      $(INSTALL) -m 755 -d $(DESTDIR)$(etcdir)
-+      $(INSTALL) -m 755 -d $(DESTDIR)$(bindir)
-+      $(INSTALL) -m 755 -d $(DESTDIR)$(sbindir)
-+      $(INSTALL) -m 755 -d $(DESTDIR)$(docdir)
-+      $(INSTALL) -m 755 -d $(DESTDIR)$(atdocdir)
-+      $(INSTALL) -m 755 -d $(DESTDIR)$(ATSPOOL_DIR) $(DESTDIR)$(ATJOB_DIR)
-       chmod 1770 $(DESTDIR)$(ATSPOOL_DIR) $(DESTDIR)$(ATJOB_DIR)
-       touch $(DESTDIR)$(LFILE)
-       chmod 600 $(DESTDIR)$(LFILE)
--      chown $(DAEMON_USERNAME):$(DAEMON_GROUPNAME) $(DESTDIR)$(LFILE)
--      test -f $(DESTDIR)$(etcdir)/at.allow || test -f $(DESTDIR)$(etcdir)/at.deny || $(INSTALL) -o root -g $(DAEMON_GROUPNAME) -m 640 at.deny $(DESTDIR)$(etcdir)/
--      $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 6755 at $(DESTDIR)$(bindir)
-+      test -f $(DESTDIR)$(etcdir)/at.allow || test -f $(DESTDIR)$(etcdir)/at.deny || $(INSTALL) -m 640 at.deny $(DESTDIR)$(etcdir)/
-+      $(INSTALL) -m 6755 at $(DESTDIR)$(bindir)
-       $(LN_S) -f at $(DESTDIR)$(bindir)/atq
-       $(LN_S) -f at $(DESTDIR)$(bindir)/atrm
--      $(INSTALL) -g root -o root -m 755 batch $(DESTDIR)$(bindir)
--      $(INSTALL) -d -o root -g root -m 755 $(DESTDIR)$(man1dir)
--      $(INSTALL) -d -o root -g root -m 755 $(DESTDIR)$(man5dir)
--      $(INSTALL) -d -o root -g root -m 755 $(DESTDIR)$(man8dir)
--      $(INSTALL) -g root -o root -m 755 atd $(DESTDIR)$(sbindir)
--      $(INSTALL) -g root -o root -m 755 atrun $(DESTDIR)$(sbindir)
--      $(INSTALL) -g root -o root -m 644 at.1 $(DESTDIR)$(man1dir)/
-+      $(INSTALL) -m 755 batch $(DESTDIR)$(bindir)
-+      $(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)
-+      $(INSTALL) -d -m 755 $(DESTDIR)$(man5dir)
-+      $(INSTALL) -d -m 755 $(DESTDIR)$(man8dir)
-+      $(INSTALL) -m 755 atd $(DESTDIR)$(sbindir)
-+      $(INSTALL) -m 755 atrun $(DESTDIR)$(sbindir)
-+      $(INSTALL) -m 644 at.1 $(DESTDIR)$(man1dir)/
-       cd $(DESTDIR)$(man1dir) && $(LN_S) -f at.1 atq.1 && $(LN_S) -f at.1 batch.1 && $(LN_S) -f at.1 atrm.1
--      $(INSTALL) -g root -o root -m 644 atd.8 $(DESTDIR)$(man8dir)/
-+      $(INSTALL) -m 644 atd.8 $(DESTDIR)$(man8dir)/
-       sed "s,\$${exec_prefix},$(exec_prefix),g" <atrun.8>tmpman
--      $(INSTALL) -g root -o root -m 644 tmpman $(DESTDIR)$(man8dir)/atrun.8
-+      $(INSTALL) -m 644 tmpman $(DESTDIR)$(man8dir)/atrun.8
-       rm -f tmpman
--      $(INSTALL) -g root -o root -m 644 at.allow.5 $(DESTDIR)$(man5dir)/
-+      $(INSTALL) -m 644 at.allow.5 $(DESTDIR)$(man5dir)/
-       cd $(DESTDIR)$(man5dir) && $(LN_S) -f at.allow.5 at.deny.5
--      $(INSTALL) -g root -o root -m 644 $(DOCS) $(DESTDIR)$(atdocdir)
-+      $(INSTALL) -m 644 $(DOCS) $(DESTDIR)$(atdocdir)
-       rm -f $(DESTDIR)$(mandir)/cat1/at.1* $(DESTDIR)$(mandir)/cat1/batch.1* \
-               $(DESTDIR)$(mandir)/cat1/atq.1*
-       rm -f $(DESTDIR)$(mandir)/cat1/atd.8*
-       if test x"$(systemdsystemunitdir)" != xno; then \
--              $(INSTALL) -o root -g root -m 755 -d $(DESTDIR)$(systemdsystemunitdir); \
--              $(INSTALL) -o root -g root -m 644 atd.service $(DESTDIR)$(systemdsystemunitdir); \
-+              $(INSTALL) -m 755 -d $(DESTDIR)$(systemdsystemunitdir); \
-+              $(INSTALL) -m 644 atd.service $(DESTDIR)$(systemdsystemunitdir); \
-       fi
- dist: checkin $(DIST) $(LIST) Filelist.asc
--- 
-2.4.10
-
diff --git a/package/at/0003-getloadavg-fix-getloadavg.c-compilation-revert-to-3..patch b/package/at/0003-getloadavg-fix-getloadavg.c-compilation-revert-to-3..patch
new file mode 100644 (file)
index 0000000..fb515af
--- /dev/null
@@ -0,0 +1,39 @@
+From 4eda31cea9fb3c77fe2748a65960f24ffb42f9ff Mon Sep 17 00:00:00 2001
+From: Peter Korsgaard <jacmet@sunsite.dk>
+Date: Fri, 23 Jul 2021 16:51:17 +0200
+Subject: [PATCH] getloadavg: fix getloadavg.c compilation, revert to 3.1.10
+ version
+
+getloadavg.c shipped with 3.1.13 doesn't compile because it references
+headers not shipped. Fix it by simply reverting to the 3.1.10 version.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
+[Giulio: convert patch to git format]
+---
+ getloadavg.c | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/getloadavg.c b/getloadavg.c
+index cf5869f..23d18eb 100644
+--- a/getloadavg.c
++++ b/getloadavg.c
+@@ -66,11 +66,12 @@ Boston, MA  02110-1301  USA */
+ /* This should always be first.  */
+ #ifdef HAVE_CONFIG_H
+-#include <config.h>
++#include "config.h"
+ #endif
+-#include "lisp.h"
+-#include "sysfile.h" /* for encapsulated open, close, read, write */
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <fcntl.h>
+ #ifndef HAVE_GETLOADAVG
+-- 
+2.25.1
+
diff --git a/package/at/0003-getloadavg.c-fix.patch b/package/at/0003-getloadavg.c-fix.patch
deleted file mode 100644 (file)
index e073927..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-[PATCH]: fix getloadavg.c compilation, revert to 3.1.10 version
-
-getloadavg.c shipped with 3.1.13 doesn't compile because it references
-headers not shipped. Fix it by simply reverting to the 3.1.10 version.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- getloadavg.c |    7 ++++---
- 1 file changed, 4 insertions(+), 3 deletions(-)
-
-Index: at-3.1.13/getloadavg.c
-===================================================================
---- at-3.1.13.orig/getloadavg.c
-+++ at-3.1.13/getloadavg.c
-@@ -66,11 +66,12 @@ Boston, MA  02110-1301  USA */
- /* This should always be first.  */
- #ifdef HAVE_CONFIG_H
--#include <config.h>
-+#include "config.h"
- #endif
--#include "lisp.h"
--#include "sysfile.h" /* for encapsulated open, close, read, write */
-+#include <sys/types.h>
-+#include <sys/stat.h>
-+#include <fcntl.h>
- #ifndef HAVE_GETLOADAVG