openzwave: fix compilation of MinOZW
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 23 Oct 2016 17:59:11 +0000 (19:59 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 24 Oct 2016 15:51:02 +0000 (17:51 +0200)
LIBDIR was used in cpp/examples/MinOZW/Makefile to add dynamic
libraries. However, as it was unset by default, the cross-compilation
could fail if the host had a library such as libnss3.so in /.
To fix this issue, this patch sets LIBDIR to top_buildir if it is unset

Fixes:
  http://autobuild.buildroot.net/results/68719fdf1320a69310bada6d3c47654dacdb5898

Signed-off-by: Fabrice Fontaine <fabrice.fontaine@orange.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openzwave/openzwave.hash
package/openzwave/openzwave.mk

index cd1231f80d2d72428a4700c79c2c6c6eef00372c..d07961edb66d87ab5589238468eef4d5b3521cc7 100644 (file)
@@ -1,2 +1,3 @@
 # Locally computed:
 sha256 abfb4c7e7728e86ba374c2e0ef7de912594eb24a8c44935457352df844530238        openzwave-V1.5.tar.gz
+sha256 98851964fd8de3dd40f00d0032b47c61c17a4cf789ad5792e14149da5ab8755e        599e2a11c6f48dde744012ec45686c08e15f3059.patch
index 2723086b82a6c4331a21877efdf13ea3431b6ab0..199d9e1bd011bbcc89ded0d4614c4e4982d94df1 100644 (file)
@@ -13,6 +13,12 @@ OPENZWAVE_LICENSE_FILES = license/license.txt license/lgpl.txt \
 OPENZWAVE_DEPENDENCIES = host-pkgconf udev
 OPENZWAVE_INSTALL_STAGING = YES
 
+# This patch fixes incorrect default value of LIBDIR:
+# http://autobuild.buildroot.net/results/68719fdf1320a69310bada6d3c47654dacdb5898
+# This patch is currently in dev branch and will be a part of v1.6
+OPENZWAVE_PATCH = \
+       https://github.com/OpenZWave/open-zwave/commit/599e2a11c6f48dde744012ec45686c08e15f3059.patch
+
 # Set instlibdir to install libopenzwave.so* in the correct directory
 # otherwise openzwave will check that /lib64 exists (on the host) to
 # know if the library should be installed in $(PREFIX)/lib or $(PREFIX)/lib64.