uclibc: set MMU usage accordingly
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 9 Aug 2013 19:23:40 +0000 (16:23 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 10 Aug 2013 08:30:08 +0000 (10:30 +0200)
On architectures that lack a MMU (like blackfin) uclibc just undefined
ARCH_HAS_MMU which disabled ARCH_USE_MMU.
But for other architectures which may or may not have one like ARM we
need to set this according to user choice.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/uclibc/uclibc.mk

index 644c531b56f8a4d2c0be36eef1a412eb517cae48..e3681c76891e85fa0ed94586666a62c2aba69538 100644 (file)
@@ -241,6 +241,20 @@ define UCLIBC_LARGEFILE_CONFIG
 endef
 endif
 
+#
+# MMU
+#
+
+ifeq ($(BR2_USE_MMU),y)
+define UCLIBC_MMU_CONFIG
+       $(call UCLIBC_OPT_SET,ARCH_USE_MMU,y,$(@D))
+endef
+else
+define UCLIBC_MMU_CONFIG
+       $(call UCLIBC_OPT_UNSET,ARCH_USE_MMU,$(@D))
+endef
+endif
+
 #
 # IPv6
 #