libatasmart: new package.
authorMarek Belisko <marek.belisko@open-nandra.com>
Fri, 18 Jan 2013 12:08:45 +0000 (12:08 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 20 Jan 2013 22:16:30 +0000 (23:16 +0100)
Signed-off-by: Marek Belisko <marek.belisko@open-nandra.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/libatasmart/Config.in [new file with mode: 0644]
package/libatasmart/libatasmart.mk [new file with mode: 0644]

index 167a52682a9b73d3d50a6b9db06f512596f956d2..f3aa1c7dd7313adca0051fa9c395359ab9708e69 100644 (file)
@@ -245,6 +245,7 @@ source "package/iostat/Config.in"
 source "package/irda-utils/Config.in"
 source "package/kbd/Config.in"
 source "package/lcdproc/Config.in"
+source "package/libatasmart/Config.in"
 source "package/lm-sensors/Config.in"
 source "package/lshw/Config.in"
 source "package/lsuio/Config.in"
diff --git a/package/libatasmart/Config.in b/package/libatasmart/Config.in
new file mode 100644 (file)
index 0000000..a3e44f8
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBATASMART
+       bool "libatasmart"
+       depends on BR2_PACKAGE_UDEV # libudev is configure dependency
+       help
+         The libatasmart package is a disk reporting library.
+         It only supports a subset of the ATA S.M.A.R.T. functionality.
+
+         http://www.linuxfromscratch.org/blfs/view/svn/general/libatasmart.html
+
+comment "libatasmart requires udev to be enabled"
+       depends on !BR2_PACKAGE_UDEV
diff --git a/package/libatasmart/libatasmart.mk b/package/libatasmart/libatasmart.mk
new file mode 100644 (file)
index 0000000..5dbdcc4
--- /dev/null
@@ -0,0 +1,18 @@
+#############################################################
+#
+# libatasmart
+#
+#############################################################
+LIBATASMART_VERSION = 0.19
+LIBATASMART_SOURCE = libatasmart-$(LIBATASMART_VERSION).tar.xz
+LIBATASMART_SITE    = http://0pointer.de/public
+LIBATASMART_LICENSE = LGPLv2.1
+LIBATASMART_LICENSE_FILE = LGPL
+LIBATASMART_INSTALL_STAGING = YES
+
+# package doesn't include configure script
+LIBATASMART_AUTORECONF = YES
+
+LIBATASMART_DEPENDENCIES = udev
+
+$(eval $(autotools-package))