qt: fix missing target
authorGwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Wed, 6 May 2015 13:28:49 +0000 (15:28 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 6 May 2015 19:33:06 +0000 (21:33 +0200)
Fix :
 http://autobuild.buildroot.net/results/093/09302c153418c3af6dc4cdd12a0149505cfbca0b/
 http://autobuild.buildroot.net/results/96f/96f8a9758f0116aec999028fde1b9c983c143809/

sh target must be provided instead of generic to have the correct QT_NO_FPU
behaviour.

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt/qt.mk

index d1615ae0bfebb8f9b3bd5c3dacfe11caa5e3b112..035ca3aacc10b57900589cbee1f0cec5d6765bf0 100644 (file)
@@ -219,6 +219,8 @@ else ifeq ($(BR2_mips)$(BR2_mipsel),y)
 QT_EMB_PLATFORM = mips
 else ifeq ($(BR2_powerpc),y)
 QT_EMB_PLATFORM = powerpc
+else ifeq ($(BR2_sh4)$(BR2_sh4eb)$(BR2_sh4a)$(BR2_sh4aeb),y)
+QT_EMB_PLATFORM = sh
 else
 QT_EMB_PLATFORM = generic
 endif