package/git: fix build failure due to gcc bug 93847
authorGiulio Benetti <giulio.benetti@benettiengineering.com>
Thu, 20 Feb 2020 15:40:04 +0000 (16:40 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 26 Feb 2020 21:14:14 +0000 (22:14 +0100)
The git package exhibits gcc bug 93847 when built for the Nios2
architecture with optimization enabled, which causes a build failure.

As done for other packages in Buildroot work around this gcc bug by
setting optimization to -O0 if BR2_TOOLCHAIN_HAS_GCC_BUG_93847=y.

Fixes:
http://autobuild.buildroot.net/results/e225e62ea2d48660df4110790664f0c3306c1ea9/

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/git/git.mk

index a5c8669fc9c47396fd991e632584cf64696f3b8b..f32a2f8eb9c0f75b8d4c8b08af1f85e3c5990d6c 100644 (file)
@@ -67,7 +67,7 @@ endif
 
 GIT_CFLAGS = $(TARGET_CFLAGS)
 
-ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180),y)
+ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180)$(BR2_TOOLCHAIN_HAS_GCC_BUG_93847),y)
 GIT_CFLAGS += -O0
 endif