package/python-canopen: new package
authorAttila Wagner <attila.wagner@onyxinsight.com>
Thu, 13 Feb 2020 13:40:40 +0000 (13:40 +0000)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Apr 2020 19:33:52 +0000 (21:33 +0200)
A Python implementation of the CANopen standard.

Signed-off-by: Attila Wagner <attila.wagner@onyxinsight.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-canopen/Config.in [new file with mode: 0644]
package/python-canopen/python-canopen.hash [new file with mode: 0644]
package/python-canopen/python-canopen.mk [new file with mode: 0644]

index bf209b45d648234a0db3ab835b6d29564fadeeb8..aae94314cfacb61d75df82128c732e0600eded46 100644 (file)
@@ -279,6 +279,9 @@ F:  package/luasec/
 F:     package/lua-ev/
 F:     package/orbit/
 
+N:     Attila Wagner <attila.wagner@onyxinsight.com>
+F:     package/python-canopen/
+
 N:     Bartosz Bilas <b.bilas@grinn-global.com>
 F:     board/stmicroelectronics/stm32mp157a-dk1/
 F:     configs/stm32mp157a_dk1_defconfig
index fce3eeff03148a31638d587376af7c2bad03076c..f7d70a1afddbc51898efdd11fdc24c39f2508400 100644 (file)
@@ -892,6 +892,7 @@ menu "External python modules"
        source "package/python-bunch/Config.in"
        source "package/python-cached-property/Config.in"
        source "package/python-can/Config.in"
+       source "package/python-canopen/Config.in"
        source "package/python-cbor/Config.in"
        source "package/python-cchardet/Config.in"
        source "package/python-certifi/Config.in"
diff --git a/package/python-canopen/Config.in b/package/python-canopen/Config.in
new file mode 100644 (file)
index 0000000..e36b8c7
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_CANOPEN
+       bool "python-canopen"
+       select BR2_PACKAGE_PYTHON_CAN # runtime
+       help
+         A Python implementation of the CANopen standard. The aim
+         of the project is to support the most common parts of the
+         CiA 301 standard in a Pythonic interface.
+
+         https://github.com/christiansandberg/canopen
diff --git a/package/python-canopen/python-canopen.hash b/package/python-canopen/python-canopen.hash
new file mode 100644 (file)
index 0000000..e1a628a
--- /dev/null
@@ -0,0 +1,4 @@
+# sha256 from https://pypi.org/pypi/canopen/json
+sha256 4394770d528e93a48936138c4a7b37b5dff26d54f82a435ad9790cd1e43f55b9  canopen-1.0.0.tar.gz
+# Locally computed sha256 checksums
+sha256 0740d30978affcd91c0fc817b7cf942a332381bf0380fe17e60c6a0b377c6e0d  LICENSE.txt
diff --git a/package/python-canopen/python-canopen.mk b/package/python-canopen/python-canopen.mk
new file mode 100644 (file)
index 0000000..fc328c6
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-canopen
+#
+################################################################################
+
+PYTHON_CANOPEN_VERSION = 1.0.0
+PYTHON_CANOPEN_SOURCE = canopen-$(PYTHON_CANOPEN_VERSION).tar.gz
+PYTHON_CANOPEN_SITE = https://files.pythonhosted.org/packages/1f/2b/55b6d82b3dcba184a01c6fe027df239953940e36a463cd24b71e67bd1f37
+PYTHON_CANOPEN_SETUP_TYPE = setuptools
+PYTHON_CANOPEN_LICENSE = MIT
+PYTHON_CANOPEN_LICENSE_FILES = LICENSE.txt
+
+$(eval $(python-package))