iso9660: take into account the linux changes
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 3 Apr 2010 16:55:43 +0000 (18:55 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 22 Jun 2010 19:20:26 +0000 (21:20 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
fs/iso9660/Config.in
fs/iso9660/iso9660.mk

index 78305814a5934450304119411e4c4793e13d1640..4c00583dc454fddb17256a4e7cc03be8c0df9ecc 100644 (file)
@@ -1,7 +1,7 @@
 config BR2_TARGET_ROOTFS_ISO9660
        bool "iso image"
-       depends on BR2_i386
-       depends on !BR2_KERNEL_none
+       depends on (BR2_i386 || BR2_x86_64)
+       depends on BR2_LINUX_KERNEL
        select BR2_TARGET_ROOTFS_EXT2
        select BR2_TARGET_GRUB
        help
@@ -13,4 +13,4 @@ config BR2_TARGET_ROOTFS_ISO9660_BOOT_MENU
        default "fs/iso9660/menu.lst"
 
 comment "iso image requires a Linux kernel to be built"
-       depends on BR2_i386 && BR2_KERNEL_none
+       depends on (BR2_i386 || BR2_x86_64) && !BR2_LINUX_KERNEL
index 66e2de20b449da92f341d5e19f69a0f302c18d67..6f60893a41da18394faef465fd05afbd287b573a 100644 (file)
@@ -15,14 +15,14 @@ ifeq ($(BR2_TARGET_ROOTFS_ISO9660_SQUASH),y)
 ISO9660_OPTS+=-U
 endif
 
-$(BINARIES_DIR)/rootfs.iso9660: host-cdrkit host-fakeroot $(LINUX_KERNEL) $(BINARIES_DIR)/rootfs.ext2 grub
+$(BINARIES_DIR)/rootfs.iso9660: host-cdrkit host-fakeroot linux26 ext2-root grub
        @$(call MESSAGE,"Generating root filesystem image rootfs.iso9660")
        mkdir -p $(ISO9660_TARGET_DIR)
        mkdir -p $(ISO9660_TARGET_DIR)/boot/grub
        cp $(GRUB_DIR)/stage2/stage2_eltorito $(ISO9660_TARGET_DIR)/boot/grub/
        cp $(ISO9660_BOOT_MENU) $(ISO9660_TARGET_DIR)/boot/grub/menu.lst
-       cp $(LINUX_KERNEL) $(ISO9660_TARGET_DIR)/kernel
-       cp $(EXT2_TARGET) $(ISO9660_TARGET_DIR)/initrd
+       cp $(LINUX26_IMAGE_PATH) $(ISO9660_TARGET_DIR)/kernel
+       cp $(BINARIES_DIR)/rootfs.ext2 $(ISO9660_TARGET_DIR)/initrd
        # Use fakeroot to pretend all target binaries are owned by root
        rm -f $(FAKEROOT_SCRIPT)
        touch $(BUILD_DIR)/.fakeroot.00000