package/fluidsynth: add systemd optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 24 Apr 2020 11:39:28 +0000 (13:39 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 7 Jan 2021 22:24:07 +0000 (23:24 +0100)
systemd is an optional dependency (enabled by default) since version
2.0.5 and
https://github.com/FluidSynth/fluidsynth/commit/099369f8b7f39afe08b6a518195948b05a937af3

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/fluidsynth/fluidsynth.mk

index c53c5d76494a1d2b8f2727176b6c91ab8bd395fe..dc777e0bf9f13f232c86698c6664ff46726816ca 100644 (file)
@@ -73,4 +73,11 @@ else
 FLUIDSYNTH_CONF_OPTS += -Denable-sdl2=0
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD),y)
+FLUIDSYNTH_CONF_OPTS += -Denable-systemd=1
+FLUIDSYNTH_DEPENDENCIES += systemd
+else
+FLUIDSYNTH_CONF_OPTS += -Denable-systemd=0
+endif
+
 $(eval $(cmake-package))