This patch updates the e2fsprogs package to build the 1.37 version of
authorEric Andersen <andersen@codepoet.org>
Mon, 16 May 2005 17:38:29 +0000 (17:38 -0000)
committerEric Andersen <andersen@codepoet.org>
Mon, 16 May 2005 17:38:29 +0000 (17:38 -0000)
e2fsprogs. This version of e2fsprogs adds additional features and increases
preformance. I've also change the configuration to build all of e2fsprogs
dynamicly linked. This reduces the size of the individual binaries
considerably.

http://bugs.uclibc.org/view.php?id=258

package/e2fsprogs/e2fsprogs.mk

index ebbceae7521fe085bcc24ec59fe41bc825c56a0c..573d49e7dcbf894448c9d7d021fb79b8de975ccc 100644 (file)
@@ -3,7 +3,7 @@
 # e2fsprogs
 #
 #############################################################
-E2FSPROGS_VER:=1.35
+E2FSPROGS_VER:=1.37
 E2FSPROGS_SOURCE=e2fsprogs-$(E2FSPROGS_VER).tar.gz
 E2FSPROGS_SITE=http://telia.dl.sourceforge.net/sourceforge/e2fsprogs
 E2FSPROGS_DIR=$(BUILD_DIR)/e2fsprogs-$(E2FSPROGS_VER)
@@ -41,9 +41,10 @@ $(E2FSPROGS_DIR)/.configured: $(E2FSPROGS_DIR)/.unpacked
                --localstatedir=/var \
                --mandir=/usr/man \
                --infodir=/usr/info \
-               --disable-elf-shlibs --disable-swapfs \
+               --enable-elf-shlibs --enable-dynamic-e2fsck --disable-swapfs \
                --disable-debugfs --disable-imager \
                --disable-resizer --enable-fsck \
+                --disable-e2initrd-helper \
                --without-catgets $(DISABLE_NLS) \
        );
        touch  $(E2FSPROGS_DIR)/.configured