util-linux: add optional dependency on readline
authorRahul Bedarkar <rahul.bedarkar@imgtec.com>
Thu, 15 Sep 2016 10:27:02 +0000 (15:57 +0530)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 16 Sep 2016 16:42:33 +0000 (18:42 +0200)
fdisk and sfdisk tools can be built with readline support. This patch
adds optional dependency on readline if it is already selected.

Signed-off-by: Rahul Bedarkar <rahul.bedarkar@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/util-linux/util-linux.mk

index aa6f994a7b096f2ac30d24389a622d08f141dd1b..7b16ca40a24ad3c532acc9d5836acd166bfa8c3d 100644 (file)
@@ -146,6 +146,13 @@ else
 UTIL_LINUX_CONF_OPTS += --without-python
 endif
 
+ifeq ($(BR2_PACKAGE_READLINE),y)
+UTIL_LINUX_CONF_OPTS += --with-readline
+UTIL_LINUX_DEPENDENCIES += readline
+else
+UTIL_LINUX_CONF_OPTS += --without-readline
+endif
+
 # Install PAM configuration files
 ifeq ($(BR2_PACKAGE_UTIL_LINUX_LOGIN_UTILS),y)
 define UTIL_LINUX_INSTALL_PAMFILES