package/gst-plugins-bad: remove apexsink support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 5 Mar 2019 22:01:04 +0000 (23:01 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 7 Mar 2019 21:32:18 +0000 (22:32 +0100)
apexsink does not build with OpenSSL 1.1.x so remove this option
especially because there is no more apexsink option in gstreamer1 (since
version 1.12)

Fixes:
 - http://autobuild.buildroot.org/results/a29e8a8509190fc4b3c419dae2301cf72a601f62

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Config.in.legacy
package/gstreamer/gst-plugins-bad/Config.in
package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk

index 25b48fba82e0574f53f0bb99c764a8d8f0dd3568..93e50f3f60da5f827a23d3b3d7c960aa78bb151c 100644 (file)
@@ -144,6 +144,14 @@ endif
 
 ###############################################################################
 
+comment "Legacy options removed in 2019.05"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_APEXSINK
+       bool "gst-plugins-bad apexsink option removed"
+       select BR2_LEGACY
+       help
+         The gst-plugins-bad apexsink option was removed.
+
 comment "Legacy options removed in 2019.02"
 
 config BR2_PACKAGE_QT
index fe8457f6d2046d51dcf5611902b1601405165d89..411e4b61744fc2c077a6eec2361c59ba4c224e89 100644 (file)
@@ -242,10 +242,6 @@ config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_Y4M
 
 comment "plugins with external dependencies (there may be more available)"
 
-config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_APEXSINK
-       bool "apexsink"
-       select BR2_PACKAGE_OPENSSL
-
 config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_BZ2
        bool "bz2"
        select BR2_PACKAGE_BZIP2
index 856ff9665deee1c0dba3bec3a4cfd8d40c08c376..a98eac4235d809c4c42439f78f3d2379cf36a568 100644 (file)
@@ -12,6 +12,7 @@ GST_PLUGINS_BAD_LICENSE = LGPL-2.1+, GPL-2.0+
 GST_PLUGINS_BAD_LICENSE_FILES = COPYING.LIB COPYING
 
 GST_PLUGINS_BAD_CONF_OPTS = \
+       --disable-apexsink \
        --disable-examples \
        --disable-spandsp
 
@@ -472,13 +473,6 @@ GST_PLUGINS_BAD_CONF_OPTS += --disable-y4m
 endif
 
 # plugins with deps
-ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_APEXSINK),y)
-GST_PLUGINS_BAD_CONF_OPTS += --enable-apexsink
-GST_PLUGINS_BAD_DEPENDENCIES += openssl
-else
-GST_PLUGINS_BAD_CONF_OPTS += --disable-apexsink
-endif
-
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_BZ2),y)
 GST_PLUGINS_BAD_CONF_OPTS += --enable-bz2
 GST_PLUGINS_BAD_DEPENDENCIES += bzip2