wireshark: add nghttp2 optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 4 Nov 2018 10:10:27 +0000 (11:10 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 6 Nov 2018 23:13:34 +0000 (00:13 +0100)
- Embedded nghttp2 code has been removed and an optional dependency to
  nghttp2 has been added with version 2.4.0 and
  https://github.com/wireshark/wireshark/commit/b1cc056b12702435f6ebdc6ba0a8e17a41e159a0
- Specify the path to found nghttp2 as this is done for other options

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/wireshark/wireshark.mk

index a141ca3e2af5b3aa6e2a0506cfcfc57f59bb42de..39a306014919fa8e708543371bfe0a9bccfefe30 100644 (file)
@@ -18,7 +18,6 @@ WIRESHARK_CONF_OPTS = \
        --enable-static=no \
        --without-bcg729 \
        --without-lz4 \
-       --without-nghttp2 \
        --without-snappy \
        --with-libsmi=no \
        --with-pcap=$(STAGING_DIR)/usr
@@ -110,6 +109,13 @@ else
 WIRESHARK_CONF_OPTS += --without-lua
 endif
 
+ifeq ($(BR2_PACKAGE_NGHTTP2),y)
+WIRESHARK_CONF_OPTS += --with-nghttp2=$(STAGING_DIR)/usr
+WIRESHARK_DEPENDENCIES += nghttp2
+else
+WIRESHARK_CONF_OPTS += --without-nghttp2
+endif
+
 ifeq ($(BR2_PACKAGE_SBC),y)
 WIRESHARK_CONF_OPTS += --with-sbc=yes
 WIRESHARK_DEPENDENCIES += sbc