mtdev2tuio: fix static linking
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Sep 2014 08:54:18 +0000 (10:54 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Sep 2014 08:54:18 +0000 (10:54 +0200)
Liblo uses log(3), so we need to link with -lm when linking statically.

Fixes http://autobuild.buildroot.net/results/bec/becda4756c577ec158536408aba59797fbed938a/

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mtdev2tuio/mtdev2tuio.mk

index b4aab5279c6e5314480cf09014a69c7e7269b734..7b00221c6a1467fe59336e79d96bb68849252023 100644 (file)
@@ -11,11 +11,12 @@ MTDEV2TUIO_LICENSE = GPLv3+
 MTDEV2TUIO_LICENSE_FILES = COPYING
 
 # mtdev2tuio Makefile misuses $(LD) as gcc, so we need to override LD
-# here.
+# here. Liblo uses log(3), so we need to link with -lm
 define MTDEV2TUIO_BUILD_CMDS
        $(MAKE) \
                $(TARGET_CONFIGURE_OPTS) \
                LD="$(TARGET_CC)" \
+               LIBS="-lmtdev -llo -lm" \
                -C $(@D)
 endef