pcre: fix target install
authorPeter Korsgaard <jacmet@sunsite.dk>
Sat, 16 Aug 2008 19:36:36 +0000 (19:36 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 16 Aug 2008 19:36:36 +0000 (19:36 -0000)
Use install-strip and clean up documentation files instead of
install-exec so files get stripped and manpages installed if
requested.

package/pcre/pcre.mk

index d28a80ce6a0f1215888e920e9a392caab8b9f812..2f86391d04c7bbe5a677db011586435daadd8e23 100644 (file)
@@ -8,6 +8,7 @@ PCRE_SOURCE = pcre-$(PCRE_VERSION).tar.bz2
 PCRE_SITE = ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre
 PCRE_INSTALL_STAGING = YES
 PCRE_INSTALL_TARGET = YES
+PCRE_INSTALL_TARGET_OPT:=DESTDIR=$(TARGET_DIR) install-strip
 
 ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
 # pcre will use the host g++ if a cross version isn't available
@@ -17,3 +18,7 @@ endif
 PCRE_DEPENDENCIES = uclibc
 
 $(eval $(call AUTOTARGETS,package,pcre))
+
+$(PCRE_HOOK_POST_INSTALL): $(PCRE_TARGET_INSTALL_TARGET)
+       rm -rf $(TARGET_DIR)/usr/share/doc/pcre
+       touch $@