package/gnuradio: add option to enable gr-dtc support
authorGwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Fri, 5 Jun 2020 13:24:32 +0000 (15:24 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 6 Jun 2020 21:13:19 +0000 (23:13 +0200)
gr-dtv provides support for a series of gnuradio blocks for digital
television standards.

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gnuradio/Config.in
package/gnuradio/gnuradio.mk

index 01a396227f6e9de3078501c2ef2114beaee1fbbc..07a33514d13ffc8106bdf6554eecdf1fa6ef3fd6 100644 (file)
@@ -54,6 +54,14 @@ config BR2_PACKAGE_GNURADIO_CTRLPORT
        help
          GNU Radio ctrlport block
 
+config BR2_PACKAGE_GNURADIO_DTV
+       bool "gr-dtv support"
+       select BR2_PACKAGE_GNURADIO_ANALOG
+       select BR2_PACKAGE_GNURADIO_FEC
+       select BR2_PACKAGE_GNURADIO_FILTER
+       help
+         various digital television standards blocks
+
 config BR2_PACKAGE_GNURADIO_FEC
        bool "gr-fec support"
        select BR2_PACKAGE_GNURADIO_BLOCKS
index 2820334996f8b02c9f14f596adb498a7efc9b06d..0a818cfc24016204608cbb6a77e7d54c093801f3 100644 (file)
@@ -93,6 +93,12 @@ else
 GNURADIO_CONF_OPTS += -DENABLE_GR_DIGITAL=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_GNURADIO_DTV),y)
+GNURADIO_CONF_OPTS += -DENABLE_GR_DTV=ON
+else
+GNURADIO_CONF_OPTS += -DENABLE_GR_DTV=OFF
+endif
+
 ifeq ($(BR2_PACKAGE_GNURADIO_FEC),y)
 GNURADIO_DEPENDENCIES += gsl
 GNURADIO_CONF_OPTS += -DENABLE_GR_FEC=ON