package/mesa3d: add explicit option for Gallium VDPAU state tracker
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 30 Sep 2019 06:01:34 +0000 (08:01 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 13 Oct 2019 21:15:25 +0000 (23:15 +0200)
Dependencies are too complex to have them handled automatically:

- needs mesa3d platform x11:
  https://cgit.freedesktop.org/mesa/mesa/tree/meson.build?h=19.2#n452
- needs specific gallium drivers:
  https://cgit.freedesktop.org/mesa/mesa/tree/meson.build?h=19.2#n459

Fixes:
http://autobuild.buildroot.net/results/a2c/a2c120193f5bace3a8bbcfa728dae7e290e15d6c/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
[Arnout: fix check-package issue]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/mesa3d/Config.in
package/mesa3d/mesa3d.mk

index d9a705f99188663f51c28d36f98eaf24c8a17b71..4cb2608e152ba660ac3a65632c7c87d8670899a3 100644 (file)
@@ -222,6 +222,23 @@ config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_VIRGL
          virgl is the 3D acceleration backend for the virtio-gpu
          shipping with qemu.
 
+config BR2_PACKAGE_MESA3D_VDPAU
+       bool "Gallium VDPAU state tracker"
+       depends on BR2_PACKAGE_XORG7
+       depends on BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_NOUVEAU \
+               || BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_R600 \
+               || BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_RADEONSI
+       select BR2_PACKAGE_LIBVDPAU
+       help
+         VDPAU state tracker (needs r600, radeonsi or nouveau gallium
+         drivers).
+
+comment "Gallium VDPAU state tracker needs X.org and gallium drivers r600, radeonsi or nouveau"
+       depends on !BR2_PACKAGE_XORG7 || \
+               !(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_NOUVEAU \
+               || BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_R600 \
+               || BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_RADEONSI)
+
 config BR2_PACKAGE_MESA3D_XVMC
        bool "Gallium XvMC state tracker"
        depends on BR2_i386 || BR2_x86_64
index b1238ec519dccc1418fcf82acb76051bc77a9693..619419a30be7913fc8ec78d43b2c2bfae9de4e26 100644 (file)
@@ -230,7 +230,7 @@ else
 MESA3D_CONF_OPTS += -Dlibunwind=false
 endif
 
-ifeq ($(BR2_PACKAGE_LIBVDPAU),y)
+ifeq ($(BR2_PACKAGE_MESA3D_VDPAU),y)
 MESA3D_DEPENDENCIES += libvdpau
 MESA3D_CONF_OPTS += -Dgallium-vdpau=true
 else