package/rygel: enable gobject-introspection support
authorAdam Duskett <Aduskett@gmail.com>
Wed, 1 Apr 2020 00:21:33 +0000 (17:21 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 6 Apr 2020 20:35:42 +0000 (22:35 +0200)
If gobject-introspection is selected, add the gobject-introspection package to
the dependency list and set the conf opt --enable-introspection.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/rygel/rygel.mk

index c43030d69fc1e328b1f8972fab693e119924c066..21c8ebee6a505d0cf47b991f725a2b260dc229af 100644 (file)
@@ -33,6 +33,13 @@ ifeq ($(BR2_PACKAGE_GDK_PIXBUF),y)
 RYGEL_DEPENDENCIES += gdk-pixbuf
 endif
 
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+RYGEL_CONF_OPTS += --enable-introspection
+RYGEL_DEPENDENCIES += gobject-introspection
+else
+RYGEL_CONF_OPTS += --disable-introspection
+endif
+
 ifeq ($(BR2_PACKAGE_RYGEL_MEDIA_ENGINE_GSTREAMER1),y)
 RYGEL_CONF_OPTS += \
        --with-media-engine=gstreamer \