package/openzwave: fix example build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 4 Aug 2021 08:31:37 +0000 (10:31 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 4 Aug 2021 21:12:14 +0000 (23:12 +0200)
-std=c++11 has been wrongly removed from CFLAGS since commit
c5ca521e232eae31276e7a12d17f0cf9d9c0108f resulting in the following
build failure:

In file included from /home/buildroot/autobuild/run/instance-1/output-1/build/openzwave-62444b0f979c337d2091d77d89cf63c2ae9775cf/cpp/src/Driver.h:38:0,
                 from /home/buildroot/autobuild/run/instance-1/output-1/build/openzwave-62444b0f979c337d2091d77d89cf63c2ae9775cf/cpp/src/Manager.h:39,
                 from Main.cpp:37:
/home/buildroot/autobuild/run/instance-1/output-1/build/openzwave-62444b0f979c337d2091d77d89cf63c2ae9775cf/cpp/src/Node.h:566:32: error: 'std::shared_ptr' has not been declared
    void SetProductDetails(std::shared_ptr<Internal::ProductDescriptor> product);
                                ^

Fixes:
 - http://autobuild.buildroot.org/results/a7999ffe3b93391b9a20dcfa3ddd9d21daf0cace

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/openzwave/openzwave.mk

index 0f639635dd7455fe58e672b0c34217c1eef50fdd..17da3b9b87d95d80055a7c1bfb843fad9f0abff5 100644 (file)
@@ -31,8 +31,8 @@ OPENZWAVE_MAKE_OPTS = \
        pkgconfigdir=/usr/lib/pkgconfig \
        sysconfdir=/etc/openzwave \
        DOXYGEN= \
-       DEBUG_CFLAGS="-fPIC" \
-       RELEASE_CFLAGS="-fPIC" \
+       DEBUG_CFLAGS="-fPIC -std=c++11" \
+       RELEASE_CFLAGS="-fPIC -std=c++11" \
        USE_BI_TXML=0
 
 ifeq ($(BR2_PACKAGE_HAS_UDEV),y)