package/lz4: only use PREFIX for host installation
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 29 Feb 2016 22:17:06 +0000 (23:17 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 29 Feb 2016 22:17:06 +0000 (23:17 +0100)
As noted by Peter Korsgaard, using DESTDIR=$(HOST_DIR) and PREFIX=/usr
for the host installation is useless and actually incorrect (the
pkg-config file contains incorrect paths). Instead, using
PREFIX=$(HOST_DIR)/usr is simpler, and actually correct.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lz4/lz4.mk

index 576b2a2273e1fa938173331de52ce7cb2057d90a..d2b09bbae4334b0d8eb48c4d4b498c66973939f7 100644 (file)
@@ -22,8 +22,8 @@ define HOST_LZ4_BUILD_CMDS
 endef
 
 define HOST_LZ4_INSTALL_CMDS
-       $(MAKE) $(HOST_CONFIGURE_OPTS) DESTDIR=$(HOST_DIR) \
-               PREFIX=/usr install -C $(@D)
+       $(MAKE) $(HOST_CONFIGURE_OPTS) PREFIX=$(HOST_DIR)/usr \
+               install -C $(@D)
 endef
 
 define LZ4_BUILD_CMDS