toolchain: have check_glibc to search deeper for ld-linux
authorJean-Mickael Guerin <jean-mickael.guerin@6wind.com>
Fri, 12 Oct 2012 10:25:50 +0000 (10:25 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 20 Oct 2012 19:05:39 +0000 (21:05 +0200)
ld-linux*.so may not be present in lib/ directory, it could be
in lib32 and/or lib64 only. But check_glibc reports
"Incorrect selection of the C library" in this case, which is
not true.
Fixed by extending the search to  SYSROOT/*/*.

Signed-off-by: Jean-Mickael Guerin <jean-mickael.guerin@6wind.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/helpers.mk

index d5ab91b3d51c22f60b0a569d4fa494c3bb94d88f..497cfff224c4b234fb370125fbeb0cbd82291dc6 100644 (file)
@@ -196,7 +196,7 @@ check_glibc_feature = \
 #
 check_glibc = \
        SYSROOT_DIR="$(strip $1)"; \
-       if test `find $${SYSROOT_DIR}/lib/ -maxdepth 1 -name 'ld-linux*.so.*' -o -name 'ld.so.*' | wc -l` -eq 0 ; then \
+       if test `find $${SYSROOT_DIR}/ -maxdepth 2 -name 'ld-linux*.so.*' -o -name 'ld.so.*' | wc -l` -eq 0 ; then \
                echo "Incorrect selection of the C library"; \
                exit -1; \
        fi; \