toolchain-external: remove support for Linaro 2012.05 toolchain
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 25 Oct 2012 22:20:26 +0000 (22:20 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 26 Oct 2012 11:12:49 +0000 (13:12 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index 7a9ec1db87adb01b12e8157c9894c60f4c1446bd..98d0c0ee4597459d368864a5c45b2825e42d03c4 100644 (file)
@@ -83,22 +83,6 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_06
 
          To use this toolchain, you must disable soft float usage.
 
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_05
-       bool "Linaro 2012.05"
-       depends on BR2_arm
-       depends on BR2_cortex_a8 || BR2_cortex_a9
-       select BR2_TOOLCHAIN_EXTERNAL_GLIBC
-       select BR2_INSTALL_LIBSTDCPP
-       help
-         Linaro toolchain for the ARM architecture. It uses Linaro
-         GCC 2012.05 (based on gcc 4.7), Linaro GDB 2012.05 (based on
-         GDB 7.4), eglibc 2.13. It generates code that runs on all
-         Cortex-A profile devices, but tuned for the Cortex-A9. The
-         code generated is Thumb 2, with the hard floating point
-         calling convention, and uses the VFPv3-D16 FPU instructions.
-
-         To use this toolchain, you must disable soft float usage.
-
 config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203
        bool "Sourcery CodeBench ARM 2012.03"
        depends on BR2_arm
@@ -648,7 +632,6 @@ config BR2_TOOLCHAIN_EXTERNAL_CUSTOM_PREFIX
 
 config BR2_TOOLCHAIN_EXTERNAL_PREFIX
        string
-       default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_05
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_06
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_07
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_08
index a7e4ab624f0f47c7d1d0cf0a937d32e7490c6324..2c85931d9b228278dbd98297b1d827ab53d7320a 100644 (file)
@@ -190,9 +190,6 @@ TOOLCHAIN_EXTERNAL_SOURCE=arm-2011.09-70-arm-none-linux-gnueabi-i686-pc-linux-gn
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203),y)
 TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/public/gnu_toolchain/arm-none-linux-gnueabi/
 TOOLCHAIN_EXTERNAL_SOURCE=arm-2012.03-57-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
-else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_05),y)
-TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.05/+download/
-TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-2012.05-20120523_linux.tar.bz2
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_06),y)
 TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.06/+download/
 TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-2012.06-20120625_linux.tar.bz2