python-bitstring: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Mon, 6 Feb 2017 15:56:24 +0000 (16:56 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 6 Feb 2017 16:17:35 +0000 (17:17 +0100)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-bitstring/Config.in [new file with mode: 0644]
package/python-bitstring/python-bitstring.hash [new file with mode: 0644]
package/python-bitstring/python-bitstring.mk [new file with mode: 0644]

index 907b1e6743b29636cd1e29f4b8708f6945a0524e..114a5ad5f974085677a38fadc77b344a622b5888 100644 (file)
@@ -655,6 +655,7 @@ menu "External python modules"
        source "package/python-babel/Config.in"
        source "package/python-backports-abc/Config.in"
        source "package/python-beautifulsoup4/Config.in"
+       source "package/python-bitstring/Config.in"
        source "package/python-bottle/Config.in"
        source "package/python-can/Config.in"
        source "package/python-cbor/Config.in"
diff --git a/package/python-bitstring/Config.in b/package/python-bitstring/Config.in
new file mode 100644 (file)
index 0000000..93d7682
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PYTHON_BITSTRING
+       bool "python-bitstring"
+       help
+         Simple construction, analysis and modification of binary data.
+
+         https://github.com/scott-griffiths/bitstring
diff --git a/package/python-bitstring/python-bitstring.hash b/package/python-bitstring/python-bitstring.hash
new file mode 100644 (file)
index 0000000..52630e0
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256 b769620c1b52d6c1548c6c4f055613f4eee3120ed8a5cff4ba4ffbbc8a582286  bitstring-3.1.5.tar.gz
diff --git a/package/python-bitstring/python-bitstring.mk b/package/python-bitstring/python-bitstring.mk
new file mode 100644 (file)
index 0000000..2c8fb99
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-bitstring
+#
+################################################################################
+
+PYTHON_BITSTRING_VERSION = 3.1.5
+PYTHON_BITSTRING_SOURCE = bitstring-$(PYTHON_BITSTRING_VERSION).tar.gz
+PYTHON_BITSTRING_SITE = https://github.com/scott-griffiths/bitstring/archive
+PYTHON_BITSTRING_SETUP_TYPE = distutils
+PYTHON_BITSTRING_LICENSE = MIT
+PYTHON_BITSTRING_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))