Some updates...
authorEric Andersen <andersen@codepoet.org>
Fri, 6 Dec 2002 04:30:19 +0000 (04:30 -0000)
committerEric Andersen <andersen@codepoet.org>
Fri, 6 Dec 2002 04:30:19 +0000 (04:30 -0000)
make/openssl.mk
make/uclibc.mk
sources/device_table.txt
sources/target_skeleton/etc/hostname
sources/target_skeleton/etc/init.d/S01mount [deleted file]
sources/target_skeleton/etc/init.d/S15modules [deleted file]
sources/target_skeleton/etc/init.d/S20syslogd [deleted file]
sources/target_skeleton/etc/init.d/S50networking [deleted file]
sources/target_skeleton/etc/inittab
sources/target_skeleton/etc/inputrc [new file with mode: 0644]
sources/target_skeleton/etc/profile

index 779a6ade850f69a77afd79bfcbe986d7aab9379f..512bcdc5f2e428a88a9157dc0dd343623b40e62f 100644 (file)
@@ -30,9 +30,9 @@ $(STAGING_DIR)/bin/openssl: $(OPENSSL_DIR)/apps/openssl
        make CC=$(TARGET_CC1) -C $(OPENSSL_DIR) install
 
 $(TARGET_DIR)/bin/openssl: $(STAGING_DIR)/bin/openssl
-       cp -fa $(STAGING_DIR)/bin/openssl  $(TARGET_DIR)/bin/
        cp -fa $(STAGING_DIR)/lib/libcrypto.so* $(TARGET_DIR)/lib/
        cp -fa $(STAGING_DIR)/lib/libssl.so* $(TARGET_DIR)/lib/
+       #cp -fa $(STAGING_DIR)/bin/openssl  $(TARGET_DIR)/bin/
 
 openssl-clean: 
        rm -f $(STAGING_DIR)/bin/openssl  $(TARGET_DIR)/bin/openssl
index 9cdbebaf262abd0534c7b739d4cd8f8c0c5b2702..68594af4eb32ef16a374193e73d5b7f860186084 100644 (file)
@@ -61,6 +61,8 @@ $(UCLIBC_DIR)/.configured: $(UCLIBC_DIR)/.unpacked
        perl -i -p -e 's,^SYSTEM_DEVEL_PREFIX=.*,SYSTEM_DEVEL_PREFIX=\"$(STAGING_DIR)\",g' $(UCLIBC_DIR)/.config
        perl -i -p -e 's,^DEVEL_TOOL_PREFIX=.*,DEVEL_TOOL_PREFIX=\"$(STAGING_DIR)/usr\",g' $(UCLIBC_DIR)/.config
        perl -i -p -e 's,^SHARED_LIB_LOADER_PATH=.*,SHARED_LIB_LOADER_PATH=\"/lib\",g' $(UCLIBC_DIR)/.config
+       perl -i -p -e 's,^GCC_BIN=.*,GCC_BIN=$(STAGING_DIR)/bin/$(ARCH)-uclibc-gcc,g'  $(UCLIBC_DIR)/extra/gcc-uClibc/Makefile
+       perl -i -p -e 's,^LD_BIN=.*,LD_BIN=$(STAGING_DIR)/bin/$(ARCH)-uclibc-ld,g'  $(UCLIBC_DIR)/extra/gcc-uClibc/Makefile     
        $(MAKE) -C $(UCLIBC_DIR) oldconfig
        touch $(UCLIBC_DIR)/.configured
 
index 5d7602d10934ddd0e92ec773b851a5f788b82f14..cf3cbb7a03f3da59ca74aada9a3c4265d6ce679e 100644 (file)
@@ -3,6 +3,7 @@
 /etc           d       755     0       0       -       -       -       -       -
 /dev           d       755     0       0       -       -       -       -       -
 /dev/pts       d       755     0       0       -       -       -       -       -
+/tmp           d       1777    0       0       -       -       -       -       -
 
 # Fixme -- add support for type 'f'
 #/bin/tinylogin        f       4755    0       0       -       -       -       -       -
index 46f514d137f6aaf712180e59acf85144bb05d0fd..52e67d68aad824cf6be0d69a4d93a66dd45efdb6 100644 (file)
@@ -1 +1 @@
-dev.null
+uclibc
diff --git a/sources/target_skeleton/etc/init.d/S01mount b/sources/target_skeleton/etc/init.d/S01mount
deleted file mode 100755 (executable)
index 45d0e7b..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-# Mount all filesystems.  We don't mess with
-# fsck, since we don't need it here...
-
-echo -n "Mounting local file systems: "
-/bin/mount / -o remount,rw > /dev/null 2>&1
-/bin/mount -a > /dev/null 2>&1
-if [ $? = 0 ] ; then
-       echo "ok"
-else
-       echo "failed"
-fi
-
-exit 0
-
diff --git a/sources/target_skeleton/etc/init.d/S15modules b/sources/target_skeleton/etc/init.d/S15modules
deleted file mode 100755 (executable)
index 4ede82d..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-if [ -f /proc/sys/kernel/modprobe ] ; then
-    echo "/bin/true" >/proc/sys/kernel/modprobe
-fi
-#/sbin/insmod foo
diff --git a/sources/target_skeleton/etc/init.d/S20syslogd b/sources/target_skeleton/etc/init.d/S20syslogd
deleted file mode 100755 (executable)
index e3b0e7d..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-echo -n "Starting system log daemon: "
-# start syslogging
-/sbin/syslogd -m 0
-echo "ok"
diff --git a/sources/target_skeleton/etc/init.d/S50networking b/sources/target_skeleton/etc/init.d/S50networking
deleted file mode 100755 (executable)
index db60359..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-# start lo all the time
-ifconfig lo 127.0.0.1 up
-route add -net 127.0.0.0 netmask 255.0.0.0 lo
-
-hostname -F /etc/hostname
index f31089f137dd45a1608a3f65c161e9ef3af65da4..a6c014e751b970af772bd2cb5bdbdb68bcfb384b 100644 (file)
 # action    == one of sysinit, respawn, askfirst, wait, and once
 # process   == program to run
 
-# main rc script
+# Startup the system
+null::sysinit:/bin/mount -o remount,rw /
+null::sysinit:/bin/mount -t proc proc /proc
+null::sysinit:/bin/mount -a
+null::sysinit:/bin/hostname -F /etc/hostname
+null::sysinit:/sbin/ifconfig lo 127.0.0.1 up
+null::sysinit:/sbin/route add -net 127.0.0.0 netmask 255.0.0.0 lo
+# now run any rc scripts
 ::sysinit:/etc/init.d/rcS
 
 # Set up a couple of getty's
-tty1::respawn:/sbin/getty 38400 tty2
-tty2::respawn:/sbin/getty 38400 tty3
+tty1::respawn:/sbin/getty 38400 tty1
+tty2::respawn:/sbin/getty 38400 tty2
 
 # Put a getty on the serial port
 #ttyS0::respawn:/sbin/getty -L ttyS0 115200 vt100
@@ -27,7 +34,7 @@ tty2::respawn:/sbin/getty 38400 tty3
 null::sysinit:/bin/touch /var/log/messages
 null::respawn:/sbin/syslogd -n -m 0
 null::respawn:/sbin/klogd -n
-tty4::respawn:/usr/bin/tail -f /var/log/messages
+tty3::respawn:/usr/bin/tail -f /var/log/messages
 
 # Stuff to do for the 3-finger salute
 ::ctrlaltdel:/sbin/reboot
diff --git a/sources/target_skeleton/etc/inputrc b/sources/target_skeleton/etc/inputrc
new file mode 100644 (file)
index 0000000..2f1cb60
--- /dev/null
@@ -0,0 +1,44 @@
+# /etc/inputrc - global inputrc for libreadline
+# See readline(3readline) and `info readline' for more information.
+
+# Be 8 bit clean.
+set input-meta on
+set output-meta on
+set bell-style visible
+
+# To allow the use of 8bit-characters like the german umlauts, comment out
+# the line below. However this makes the meta key not work as a meta key,
+# which is annoying to those which don't need to type in 8-bit characters.
+
+# set convert-meta off
+
+"\e0d": backward-word
+"\e0c": forward-word
+"\e[h": beginning-of-line
+"\e[f": end-of-line
+"\e[1~": beginning-of-line
+"\e[4~": end-of-line
+#"\e[5~": beginning-of-history
+#"\e[6~": end-of-history
+"\e[3~": delete-char
+"\e[2~": quoted-insert
+
+# Common standard keypad and cursor
+# (codes courtsey Werner Fink, <werner@suse.de>)
+#"\e[1~": history-search-backward
+"\e[2~": yank
+"\e[3~": delete-char
+#"\e[4~": set-mark
+"\e[5~": history-search-backward
+"\e[6~": history-search-forward
+# Normal keypad and cursor of xterm
+"\e[F": end-of-line
+"\e[H": beginning-of-line
+# Application keypad and cursor of xterm
+"\eOA": previous-history
+"\eOC": forward-char
+"\eOB": next-history
+"\eOD": backward-char
+"\eOF": end-of-line
+"\eOH": beginning-of-line
+
index 66ef8fedfaf478ced368c6620e5a14b682331a71..cc2e0beb87bc855836cf184db4deaac2aad09b74 100644 (file)
@@ -1,9 +1,48 @@
-PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
-alias ll='ls -l'
+# ~/.bashrc: executed by bash(1) for non-login interactive shells.
 
-echo " "
-echo " "
-echo "Welcome to the busybox/uClibc usermode-linux test environment"
-echo " "
-echo " "
+export PATH=\
+/bin:\
+/sbin:\
+/usr/bin:\
+/usr/sbin:\
+/usr/bin/X11:\
+/usr/local/bin
 
+# If running interactively, then:
+if [ "$PS1" ]; then
+
+    if [ "$BASH" ]; then
+       export PS1="[\u@\h \W]\\$ "
+       alias ll='/bin/ls --color=tty -laFh'
+       alias ls='/bin/ls --color=tty -F'
+       export LS_COLORS='no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.jpg=01;35:*.jpeg=01;35:*.png=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.mpg=01;35:*.mpeg=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:';
+    else
+      if [ "`id -u`" -eq 0 ]; then 
+       export PS1='# '
+      else
+       export PS1='$ '
+      fi
+    fi
+
+    export USER=`id -un`
+    export LOGNAME=$USER
+    export HOSTNAME=`/bin/hostname`
+    export HISTSIZE=1000
+    export HISTFILESIZE=1000
+    export PAGER='/bin/more '
+    export EDITOR='/bin/vi'
+    export INPUTRC=/etc/inputrc
+    export DMALLOC_OPTIONS=debug=0x34f47d83,inter=100,log=logfile
+
+    ### Some aliases
+    alias ps2='ps facux '
+    alias ps1='ps faxo "%U %t %p %a" '
+    alias af='ps af'
+    alias cls='clear'
+    alias df='df -h'
+    alias indent='indent -bad -bap -bbo -nbc -br -brs -c33 -cd33 -ncdb -ce -ci4 -cli0 -cp33 -cs -d0 -di1 -nfc1 -nfca -hnl -i4 -ip0 -l75 -lp -npcs -npsl -nsc -nsob -nss -ts4 '
+    #alias bc='bc -l'
+    alias minicom='minicom -c on'
+    alias calc='calc -Cd '
+    alias bc='calc -Cd '
+fi;