projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
7720ca3
)
package/libselinux: enable kernel selinux support for squashfs images
author
Adam Duskett
<Aduskett@gmail.com>
Fri, 31 Jul 2020 20:40:59 +0000
(13:40 -0700)
committer
Thomas Petazzoni
<thomas.petazzoni@bootlin.com>
Fri, 4 Sep 2020 13:43:51 +0000
(15:43 +0200)
If BR2_TARGET_ROOTFS_SQUASHFS is selected, enable the following kernel options:
- CONFIG_SQUASHFS_XATTR
Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libselinux/libselinux.mk
patch
|
blob
|
history
diff --git
a/package/libselinux/libselinux.mk
b/package/libselinux/libselinux.mk
index 3dee9222147252b6124184995ca0cfe642c26469..f2c29221228fcd32e442c1f309db31c8cc559c40 100644
(file)
--- a/
package/libselinux/libselinux.mk
+++ b/
package/libselinux/libselinux.mk
@@
-127,6
+127,8
@@
define LIBSELINUX_LINUX_CONFIG_FIXUPS
$(call KCONFIG_ENABLE_OPT,CONFIG_F2FS_FS_SECURITY))
$(if $(BR2_TARGET_ROOTFS_JFFS2),
$(call KCONFIG_ENABLE_OPT,CONFIG_JFS_SECURITY))
+ $(if $(BR2_TARGET_ROOTFS_SQUASHFS),
+ $(call KCONFIG_ENABLE_OPT,CONFIG_SQUASHFS_XATTR))
endef
$(eval $(generic-package))