package/kodi-peripheral-joystick: bump version
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 19 Jan 2020 11:07:19 +0000 (12:07 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Thu, 23 Jan 2020 00:04:02 +0000 (01:04 +0100)
Removed dependency to kodi-platform
https://github.com/xbmc/peripheral.joystick/commit/a9489ea0f08bbf04affb798857439540478ff90d

Added dependency to tinyxml
https://github.com/xbmc/peripheral.joystick/commit/471aa27d6c8ff9c9d0ac50c1b32f1504840194b5

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/kodi-peripheral-joystick/Config.in
package/kodi-peripheral-joystick/kodi-peripheral-joystick.hash
package/kodi-peripheral-joystick/kodi-peripheral-joystick.mk

index f257710a88f2a8ae16b04d7f9332832614b49b2e..d93e71b607323f7483d963bc84bd35d7dc2472a3 100644 (file)
@@ -1,7 +1,7 @@
 config BR2_PACKAGE_KODI_PERIPHERAL_JOYSTICK
        bool "kodi-peripheral-joystick"
        depends on BR2_PACKAGE_HAS_UDEV
-       select BR2_PACKAGE_KODI_PLATFORM
+       select BR2_PACKAGE_TINYXML
        help
          Kodi joystick support (drivers and button maps)
 
index 5a7348d4144810e3ad396317658f5e36ae7ccf4c..84f847f309f9a1cf03625e90f2565344975d29ed 100644 (file)
@@ -1,2 +1,2 @@
 # Locally computed
-sha256 9a183e1f92ff2c68816bfa0056c65585a3e1129d924326359d7a5dfbcba6c56a  kodi-peripheral-joystick-1.3.4.tar.gz
+sha256 b6ddefed73582a3dc9bc36a9d40f8309139802ef9cfc130933bd0fe6e569d933  kodi-peripheral-joystick-1.4.8-Leia.tar.gz
index 13c33fc0affcb44f84ce29d15e54dadf6d8a1279..c56cfef43f803c76e94ba50b84c2375a19118254 100644 (file)
@@ -4,12 +4,10 @@
 #
 ################################################################################
 
-# This cset is on the branch 'Krypton'
-# When Kodi is updated, then this should be updated to the corresponding branch
-KODI_PERIPHERAL_JOYSTICK_VERSION = 1.3.4
-KODI_PERIPHERAL_JOYSTICK_SITE = $(call github,xbmc,peripheral.joystick,v$(KODI_PERIPHERAL_JOYSTICK_VERSION))
+KODI_PERIPHERAL_JOYSTICK_VERSION = 1.4.8-Leia
+KODI_PERIPHERAL_JOYSTICK_SITE = $(call github,xbmc,peripheral.joystick,$(KODI_PERIPHERAL_JOYSTICK_VERSION))
 KODI_PERIPHERAL_JOYSTICK_LICENSE = GPL-2.0+
 KODI_PERIPHERAL_JOYSTICK_LICENSE_FILES = src/addon.cpp
-KODI_PERIPHERAL_JOYSTICK_DEPENDENCIES = kodi-platform udev
+KODI_PERIPHERAL_JOYSTICK_DEPENDENCIES = kodi tinyxml udev
 
 $(eval $(cmake-package))