freetype: freetype-patch: depends on host-automake
authorFabio Porcedda <fabio.porcedda@gmail.com>
Mon, 5 May 2014 14:08:22 +0000 (16:08 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 11 May 2014 21:11:44 +0000 (23:11 +0200)
The "make freetype-patch" fails because does not found autogen.sh,
because autogen.sh available only for the configure stage.
To fix this add host-automake as a prerequisite to freetype-patch.

This change also fix the support to top-level parallel make.

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Cc: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/freetype/freetype.mk

index c7c9a069594485b6f72aecd76b6bf19090ea0212..a6ae0a05f555c293b613c48324cf51e56c5013d0 100644 (file)
@@ -83,3 +83,7 @@ HOST_FREETYPE_POST_INSTALL_HOOKS += HOST_FREETYPE_FIX_FREETYPE_INCLUDE
 
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))
+
+# freetype-patch uses autogen.sh so add it as a order-only-prerequisite
+# because it is a phony target.
+$(FREETYPE_TARGET_PATCH): | host-automake