lua-cqueues: new package
authorFrancois Perrad <fperrad@gmail.com>
Sun, 24 Sep 2017 16:18:56 +0000 (18:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 3 Oct 2017 20:04:44 +0000 (22:04 +0200)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/lua-cqueues/Config.in [new file with mode: 0644]
package/lua-cqueues/lua-cqueues.hash [new file with mode: 0644]
package/lua-cqueues/lua-cqueues.mk [new file with mode: 0644]

index c2c0901a4937db24cd385329d90f3f245f950ca6..560d29651fcbc598dbcdd1a25264bf46291ff7f3 100644 (file)
@@ -579,6 +579,7 @@ menu "Lua libraries/modules"
        source "package/lua-cjson/Config.in"
        source "package/lua-coat/Config.in"
        source "package/lua-coatpersistent/Config.in"
+       source "package/lua-cqueues/Config.in"
        source "package/lua-csnappy/Config.in"
        source "package/lua-curl/Config.in"
        source "package/lua-datafile/Config.in"
diff --git a/package/lua-cqueues/Config.in b/package/lua-cqueues/Config.in
new file mode 100644 (file)
index 0000000..60f0228
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_LUA_CQUEUES
+       bool "lua-cqueues"
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       select BR2_PACKAGE_OPENSSL
+       help
+         Continuation Queues: Embeddable asynchronous networking,
+         threading, and notification framework for Lua on Unix.
+
+         http://25thandclement.com/~william/projects/cqueues.html
+
+comment "lua-cqueues needs a toolchain w/ threads"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/lua-cqueues/lua-cqueues.hash b/package/lua-cqueues/lua-cqueues.hash
new file mode 100644 (file)
index 0000000..9fd664d
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 ae51b713bdf966215b87244e03ac60b5a12beb82d15dfb02755a000cfb2df905  lua-cqueues-rel-20161215.tar.gz
diff --git a/package/lua-cqueues/lua-cqueues.mk b/package/lua-cqueues/lua-cqueues.mk
new file mode 100644 (file)
index 0000000..4f4be1e
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# lua-cqueues
+#
+################################################################################
+
+LUA_CQUEUES_VERSION = rel-20161215
+LUA_CQUEUES_SITE = $(call github,wahern,cqueues,$(LUA_CQUEUES_VERSION))
+LUA_CQUEUES_LICENSE = MIT
+LUA_CQUEUES_LICENSE_FILES = LICENSE
+LUA_CQUEUES_DEPENDENCIES = luainterpreter openssl
+
+define LUA_CQUEUES_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE1) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
+               prefix="$(STAGING_DIR)/usr" all$(LUAINTERPRETER_ABIVER)
+endef
+
+define LUA_CQUEUES_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE1) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
+               DESTDIR="$(TARGET_DIR)" prefix=/usr install$(LUAINTERPRETER_ABIVER)
+endef
+
+$(eval $(generic-package))