lighttpd: use upstream systemd service file
authorMike Williams <mike@mikebwilliams.com>
Fri, 20 Mar 2015 19:13:52 +0000 (15:13 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 20 Mar 2015 19:32:43 +0000 (20:32 +0100)
Signed-off-by: Mike Williams <mike@mikebwilliams.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lighttpd/lighttpd.mk
package/lighttpd/lighttpd.service [deleted file]

index 8f34561d2116a0a009081616ecb908cbd3d62dc7..cdbf91dc4caa3b44d41e843722dd95d9bd2c2473 100644 (file)
@@ -84,12 +84,12 @@ define LIGHTTPD_INSTALL_INIT_SYSV
 endef
 
 define LIGHTTPD_INSTALL_INIT_SYSTEMD
-       $(INSTALL) -D -m 0644 package/lighttpd/lighttpd.service \
-               $(TARGET_DIR)/etc/systemd/system/lighttpd.service
+       $(INSTALL) -D -m 0644 $(@D)/doc/systemd/lighttpd.service \
+               $(TARGET_DIR)/usr/lib/systemd/system/lighttpd.service
 
        mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
 
-       ln -fs ../lighttpd.service \
+       ln -fs ../../../../usr/lib/systemd/lighttpd.service \
                $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/lighttpd.service
 endef
 
diff --git a/package/lighttpd/lighttpd.service b/package/lighttpd/lighttpd.service
deleted file mode 100644 (file)
index 0ca5357..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Lighttpd Web Server
-After=network.target
-
-[Service]
-ExecStart=/usr/sbin/lighttpd-angel -f /etc/lighttpd/lighttpd.conf -D
-ExecReload=/bin/kill -HUP $MAINPID
-
-[Install]
-WantedBy=multi-user.target