package/norm: make it a waf-package
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 30 Oct 2016 16:02:21 +0000 (17:02 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 2 Dec 2016 21:38:22 +0000 (22:38 +0100)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/norm/norm.mk

index e1b3a5fcc2f4f247ae99ab9e68a5d46aac4d2fde..8af76f8345867ecff020654a3aa0b606ecf935b4 100644 (file)
@@ -15,32 +15,10 @@ ifeq ($(BR2_PACKAGE_LIBNETFILTER_QUEUE),y)
 NORM_DEPENDENCIES += libnetfilter_queue
 endif
 
-define NORM_CONFIGURE_CMDS
-       cd $(@D); \
-               $(TARGET_CONFIGURE_OPTS) \
-               ./waf configure --prefix=/usr
-endef
-
-define NORM_BUILD_CMDS
-       cd $(@D); \
-               $(TARGET_MAKE_ENV) \
-               ./waf build
-endef
-
 # install target doesn't install headers unfortunately...
-define NORM_INSTALL_STAGING_CMDS
-       cd $(@D); \
-               $(TARGET_MAKE_ENV) \
-               DESTDIR=$(STAGING_DIR) \
-               ./waf install
+define NORM_INSTALL_HEADERS
        cp -f $(@D)/include/norm* $(STAGING_DIR)/usr/include
 endef
+NORM_POST_INSTALL_STAGING_HOOKS += NORM_INSTALL_HEADERS
 
-define NORM_INSTALL_TARGET_CMDS
-       cd $(@D); \
-               $(TARGET_MAKE_ENV) \
-               DESTDIR=$(TARGET_DIR) \
-               ./waf install
-endef
-
-$(eval $(generic-package))
+$(eval $(waf-package))