libfslvpuwrap: Use self-extractible helper
authorJérôme Pouiller <jezz@sysmic.org>
Wed, 19 Nov 2014 21:30:39 +0000 (22:30 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 27 Nov 2014 21:00:17 +0000 (22:00 +0100)
[Thomas: remove unneeded comment.]

Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libfslvpuwrap/libfslvpuwrap.mk

index c3a5c1c742647b1f402e6c046c94eeb769b42be7..01b29995926989d26cd81173cd08d2fdac3b78e4 100644 (file)
@@ -7,30 +7,15 @@
 LIBFSLVPUWRAP_VERSION = 1.0.46
 LIBFSLVPUWRAP_SITE = $(FREESCALE_IMX_SITE)
 LIBFSLVPUWRAP_SOURCE = libfslvpuwrap-$(LIBFSLVPUWRAP_VERSION).bin
+LIBFSLVPUWRAP_DEPENDENCIES = imx-vpu
+LIBFSLVPUWRAP_INSTALL_STAGING = YES
+
 LIBFSLVPUWRAP_LICENSE = Freescale Semiconductor Software License Agreement
-# N.B.: the content of the two license files is different
 LIBFSLVPUWRAP_LICENSE_FILES = EULA EULA.txt
 LIBFSLVPUWRAP_REDISTRIBUTE = NO
 
-LIBFSLVPUWRAP_INSTALL_STAGING = YES
-
-LIBFSLVPUWRAP_DEPENDENCIES += imx-vpu
-
-# The archive is a shell-self-extractor of a bzipped tar. It happens
-# to extract in the correct directory (libfslvpuwrap-x.y.z)
-# The --force makes sure it doesn't fail if the source dir already exists.
-# The --auto-accept skips the license check - not needed for us
-# because we have legal-info
-# Since the EULA in the bin file differs from the one in the tar file,
-# extract the one from the bin file as well.
 define LIBFSLVPUWRAP_EXTRACT_CMDS
-       awk 'BEGIN      { start=0; } \
-            /^EOEULA/  { start = 0; } \
-                       { if (start) print; } \
-            /<<EOEULA/ { start=1; }'\
-           $(DL_DIR)/$(LIBFSLVPUWRAP_SOURCE) > $(@D)/EULA
-       cd $(BUILD_DIR); \
-       sh $(DL_DIR)/$(LIBFSLVPUWRAP_SOURCE) --force --auto-accept
+       $(call FREESCALE_IMX_EXTRACT_HELPER,$(DL_DIR)/$(LIBFSLVPUWRAP_SOURCE))
 endef
 
 $(eval $(autotools-package))