target-finalize: do not strip libthread_db.so
authorMike Frysinger <vapier@gentoo.org>
Sat, 20 Nov 2010 10:29:28 +0000 (05:29 -0500)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 24 Nov 2010 21:24:06 +0000 (22:24 +0100)
For proper threading debug support, the libthread_db.so library cannot
be stripped on the target.  This is because the target gdbserver will
also load up this library at runtime and poke around its symbols.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 86aea91a25b4b42091029180877ba067426e6228..22ae1d0604c84c470c7296ede733d73ee925bae1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -418,7 +418,8 @@ ifneq ($(BR2_HAVE_DOCUMENTATION),y)
        rm -rf $(TARGET_DIR)/usr/share/gtk-doc
        -rmdir $(TARGET_DIR)/usr/share 2>/dev/null
 endif
-       find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIPCMD) 2>/dev/null || true
+       find $(TARGET_DIR) -type f -perm +111 '!' -name 'libthread_db.so*' | \
+               xargs $(STRIPCMD) 2>/dev/null || true
        find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \
                xargs -r $(STRIPCMD) $(STRIP_STRIP_UNNEEDED)