dropbear: Do not build static binary
authorStefan Sørensen <stefan.sorensen@spectralink.com>
Mon, 7 May 2018 12:28:43 +0000 (14:28 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 8 May 2018 13:09:25 +0000 (15:09 +0200)
Dropbear 2018.76 now uses the --enable-static option to indicate that a static
binary should be built. This will incorrectly pick up the generic buildroot
option intended for building static libraries, causing an unwanted static
binary build with BR2_SHARED_STATIC_LIBS.

Fix by appending an --disable-static configure flag, overriding the buildroot
default.

Signed-off-by: Stefan Sørensen <stefan.sorensen@spectralink.com>
Reviewed-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/dropbear/dropbear.mk

index 1da1a559a30a5e1e776185d5dd1635fc2629b51c..fc41a84c1ff62e9f7f34f5eab14c4cb2e6ec6440 100644 (file)
@@ -27,8 +27,11 @@ DROPBEAR_MAKE = \
        $(MAKE) MULTI=1 SCPPROGRESS=1 \
        PROGRAMS="$(DROPBEAR_PROGRAMS)"
 
-ifeq ($(BR2_STATIC_LIBS),y)
-DROPBEAR_CONF_OPTS += --enable-static
+# With BR2_SHARED_STATIC_LIBS=y the generic infrastructure adds a
+# --enable-static flags causing dropbear to be built as a static
+# binary. Adding a --disable-static reverts this
+ifeq ($(BR2_SHARED_STATIC_LIBS),y)
+DROPBEAR_CONF_OPTS += --disable-static
 endif
 
 # Ensure that dropbear doesn't use crypt() when it's not available