python-pyroute2: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Tue, 11 Aug 2015 15:35:26 +0000 (17:35 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 18 Aug 2015 21:13:24 +0000 (23:13 +0200)
[Thomas:
  - fix legal info:
    * the license is GPLv2+ *or* Apache 2.0
    * the license files list separator is space, not comma
    * README.license.md has been added to the license files, since it
      contains some useful information about the licensing.
  - rewrap Config.in help text.]

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-pyroute2/Config.in [new file with mode: 0644]
package/python-pyroute2/python-pyroute2.mk [new file with mode: 0644]

index 3ab87cf461c838c4cea6c802a55bfe098494c002..729df7a38a218d5c9cfe7df8c87013ba01266150 100644 (file)
@@ -646,6 +646,7 @@ menu "external python modules"
        source "package/python-pypcap/Config.in"
        source "package/python-pyqt/Config.in"
        source "package/python-pyro/Config.in"
+       source "package/python-pyroute2/Config.in"
        source "package/python-pysendfile/Config.in"
        source "package/python-pysnmp/Config.in"
        source "package/python-pysnmp-apps/Config.in"
diff --git a/package/python-pyroute2/Config.in b/package/python-pyroute2/Config.in
new file mode 100644 (file)
index 0000000..4f13ab2
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_PYROUTE2
+       bool "python-pyroute2"
+       help
+         Python netlink library - Linux network / netns / wireless /
+         ipset configuration.
+
+         https://github.com/svinota/pyroute2
diff --git a/package/python-pyroute2/python-pyroute2.mk b/package/python-pyroute2/python-pyroute2.mk
new file mode 100644 (file)
index 0000000..61de195
--- /dev/null
@@ -0,0 +1,21 @@
+#############################################################
+#
+# python-pyroute2
+#
+#############################################################
+
+PYTHON_PYROUTE2_VERSION = 16a8aced82c65b94eb9e15a7d773a3256763d155
+PYTHON_PYROUTE2_SITE = $(call github,svinota,pyroute2,$(PYTHON_PYROUTE2_VERSION))
+PYTHON_PYROUTE2_LICENSE = Apache-2.0 or GPLv2+
+PYTHON_PYROUTE2_LICENSE_FILES = LICENSE.Apache.v2 LICENSE.GPL.v2 README.license.md
+PYTHON_PYROUTE2_SETUP_TYPE = distutils
+PYTHON_PYROUTE2_DEPENDENCIES = host-gawk
+
+# this hook is needed to create setup.py from setup.py.in
+define PYTHON_PYROUTE2_CREATE_SETUP_PY
+       $(TARGET_MAKE_ENV) $(MAKE1) -C $(@D) update-version
+endef
+
+PYTHON_PYROUTE2_PRE_CONFIGURE_HOOKS += PYTHON_PYROUTE2_CREATE_SETUP_PY
+
+$(eval $(python-package))