package/wireplumber: new package
authorJames Hilliard <james.hilliard1@gmail.com>
Sun, 12 Sep 2021 22:04:57 +0000 (16:04 -0600)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 21 Sep 2021 20:39:28 +0000 (22:39 +0200)
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/Config.in
package/wireplumber/Config.in [new file with mode: 0644]
package/wireplumber/wireplumber.hash [new file with mode: 0644]
package/wireplumber/wireplumber.mk [new file with mode: 0644]

index 899b49318006ad40e6997e882072926b63b95d30..f2f80da3ff285c9402c86b999294588a16c04024 100644 (file)
@@ -1539,6 +1539,7 @@ menu "Graphics"
        source "package/waylandpp/Config.in"
        source "package/webkitgtk/Config.in"
        source "package/webp/Config.in"
+       source "package/wireplumber/Config.in"
        source "package/wlroots/Config.in"
        source "package/woff2/Config.in"
        source "package/wpebackend-fdo/Config.in"
diff --git a/package/wireplumber/Config.in b/package/wireplumber/Config.in
new file mode 100644 (file)
index 0000000..6528a2e
--- /dev/null
@@ -0,0 +1,22 @@
+config BR2_PACKAGE_WIREPLUMBER
+       bool "wireplumber"
+       depends on BR2_PACKAGE_PIPEWIRE
+       depends on BR2_PACKAGE_LUA_5_3 || BR2_PACKAGE_LUA_5_4
+       depends on BR2_USE_WCHAR # libglib2
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
+       depends on BR2_USE_MMU # libglib2
+       select BR2_PACKAGE_LIBGLIB2
+       help
+         WirePlumber is a modular session / policy manager for
+         PipeWire and a GObject-based high-level library that
+         wraps PipeWire’s API, providing convenience for writing
+         the daemon’s modules as well as external tools for
+         managing PipeWire.
+
+         https://pipewire.pages.freedesktop.org/wireplumber/
+
+comment "wireplumber needs a toolchain w/ wchar, threads and Lua >= 5.3"
+       depends on BR2_PACKAGE_PIPEWIRE
+       depends on BR2_USE_MMU
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || \
+               (!BR2_PACKAGE_LUA_5_3 && !BR2_PACKAGE_LUA_5_4)
diff --git a/package/wireplumber/wireplumber.hash b/package/wireplumber/wireplumber.hash
new file mode 100644 (file)
index 0000000..561fcc2
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256  41f174eaae5a630e195001fdd580918fa5143a71edceb050b320f85a8e65e53b  wireplumber-0.4.2.tar.bz2
+sha256  ff2eb9af5b05d92ac3a38cffcad27582ef555a31ff1781e1c1d4e087f77c9c81  LICENSE
diff --git a/package/wireplumber/wireplumber.mk b/package/wireplumber/wireplumber.mk
new file mode 100644 (file)
index 0000000..2dab604
--- /dev/null
@@ -0,0 +1,39 @@
+################################################################################
+#
+# wireplumber
+#
+################################################################################
+
+WIREPLUMBER_VERSION = 0.4.2
+WIREPLUMBER_SOURCE = wireplumber-$(WIREPLUMBER_VERSION).tar.bz2
+WIREPLUMBER_SITE = https://gitlab.freedesktop.org/pipewire/wireplumber/-/archive/$(WIREPLUMBER_VERSION)
+WIREPLUMBER_LICENSE = MIT
+WIREPLUMBER_LICENSE_FILES = LICENSE
+WIREPLUMBER_DEPENDENCIES = host-pkgconf dbus pipewire libglib2 lua
+
+WIREPLUMBER_CONF_OPTS = \
+       -Ddoc=disabled \
+       -Dsystem-lua=true \
+       -Dsystem-lua-version=
+
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+WIREPLUMBER_DEPENDENCIES += gobject-introspection
+WIREPLUMBER_CONF_OPTS += -Dintrospection=enabled
+else
+WIREPLUMBER_CONF_OPTS += -Dintrospection=disabled
+endif
+
+ifeq ($(BR2_PACKAGE_SYSTEMD),y)
+WIREPLUMBER_DEPENDENCIES += systemd
+WIREPLUMBER_CONF_OPTS += \
+       -Dsystemd=enabled \
+       -Dsystemd-system-service=true \
+       -Dsystemd-user-service=true
+else
+WIREPLUMBER_CONF_OPTS += \
+       -Dsystemd=disabled \
+       -Dsystemd-system-service=false \
+       -Dsystemd-user-service=false
+endif
+
+$(eval $(meson-package))