package/libvirt: nss needs yajl
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 7 Aug 2021 16:34:44 +0000 (18:34 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 8 Aug 2021 21:06:40 +0000 (23:06 +0200)
nss can't be built without yajl since the additoon of the package in
commit ccfc90e1010e42e6529afae3a5ea8bf7226dabc1:

../output-1/build/libvirt-7.4.0/meson.build:1986:6: ERROR: Problem encountered: Can't build nss plugin without yajl

Fixes:
 - http://autobuild.buildroot.org/results/18db9ec30d5e60fbe9f5096c3fd1a30396e11856

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libvirt/libvirt.mk

index 108996942d3a9f2348ca91aa86b50c381997fade..b36cf3fb60c4d400e7b24e108cb4e403854c739f 100644 (file)
@@ -187,8 +187,8 @@ else
 LIBVIRT_CONF_OPTS += -Dlibssh=disabled
 endif
 
-# Can't build nss plugin without network
-ifeq ($(BR2_PACKAGE_LIBNSS),y)
+# Can't build nss plugin without network or yajl
+ifeq ($(BR2_PACKAGE_LIBNSS)$(BR2_PACKAGE_YAJL),yy)
 LIBVIRT_CONF_OPTS += -Dnss=enabled
 LIBVIRT_DEPENDENCIES += libnss
 else