linux.mk: .ub-File copying after building initramfs
authorMarkus Kaindl <markus.kaindl@stusta.mhn.de>
Wed, 21 Mar 2012 01:19:04 +0000 (02:19 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 21 Mar 2012 10:44:22 +0000 (11:44 +0100)
test should exit with Exit-Code 0 if no .ub-File present and copy the
file if Exit-Code 1, otherwise make fails

Signed-off-by: Markus Kaindl <markus.kaindl@stusta.mhn.de>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
linux/linux.mk

index c0334d2b7e7d4ad535be18349c1d82e90d6d79be..6cb1efc86afd064b0a18b68b7966f22b59bdb74e 100644 (file)
@@ -230,7 +230,7 @@ $(LINUX_DIR)/.stamp_initramfs_rebuilt: $(LINUX_DIR)/.stamp_target_installed $(LI
        # Copy the kernel image to its final destination
        cp $(LINUX_IMAGE_PATH) $(BINARIES_DIR)
        # If there is a .ub file copy it to the final destination
-       test -f $(LINUX_IMAGE_PATH).ub && cp $(LINUX_IMAGE_PATH).ub $(BINARIES_DIR)
+       test ! -f $(LINUX_IMAGE_PATH).ub || cp $(LINUX_IMAGE_PATH).ub $(BINARIES_DIR)
        $(Q)touch $@
 
 # The initramfs building code must make sure this target gets called