package/squid: remove gnu atomics handling
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 24 Nov 2018 14:54:49 +0000 (15:54 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 29 Nov 2018 21:57:34 +0000 (22:57 +0100)
gnu atomics has been removed since version 3.5.27:
https://github.com/squid-cache/squid/commit/ddd4edb743d82be97fc651d529e04bf55329a50d
So remove squid_cv_gnu_atomics handling

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/squid/squid.mk

index b661d5d133ed99f98df1ec597b46d34b3f7fab33..2b6c830a621f9d0a5fcb809ada749fc3cf2bd921 100644 (file)
@@ -38,15 +38,6 @@ SQUID_CONF_OPTS = \
        --with-swapdir=/var/cache/squid/ \
        --with-default-user=squid
 
-# Atomics in Squid use __sync built-ins on 4 and 8 bytes. However, the
-# configure script tests them using AC_TRY_RUN, so we have to give
-# some hints.
-ifeq ($(BR2_TOOLCHAIN_HAS_SYNC_4)$(BR2_TOOLCHAIN_HAS_SYNC_8),yy)
-SQUID_CONF_ENV += squid_cv_gnu_atomics=yes
-else
-SQUID_CONF_ENV += squid_cv_gnu_atomics=no
-endif
-
 ifeq ($(BR2_PACKAGE_LIBKRB5),y)
 SQUID_CONF_OPTS += --with-mit-krb5
 SQUID_DEPENDENCIES += libkrb5