package/libexif: security bump to version 0.6.22
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 19 May 2020 18:02:16 +0000 (20:02 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 19 May 2020 19:59:51 +0000 (21:59 +0200)
- Switch site to github
- Drop patches (already in version)
- Fix the following CVEs:
  - CVE-2020-13114: Time consumption DoS when parsing canon array
    markers
  - CVE-2020-13113: Potential use of uninitialized memory
  - CVE-2020-13112: Various buffer overread fixes due to integer
    overflows in maker notes
  - CVE-2020-0093: read overflow
  - CVE-2020-12767: fixed division by zero

https://github.com/libexif/libexif/releases/tag/libexif-0_6_22-release

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libexif/0001-fixes-some-not-all-buffer-overreads-during-decoding-.patch [deleted file]
package/libexif/0002-On-saving-makernotes-make-sure-the-makernote-contain.patch [deleted file]
package/libexif/0003-Reduce-maximum-recursion-depth-in-exif_data_load_dat.patch [deleted file]
package/libexif/0004-Improve-deep-recursion-detection-in-exif_data_load_d.patch [deleted file]
package/libexif/0005-fix-CVE-2019-9278.patch [deleted file]
package/libexif/Config.in
package/libexif/libexif.hash
package/libexif/libexif.mk

diff --git a/package/libexif/0001-fixes-some-not-all-buffer-overreads-during-decoding-.patch b/package/libexif/0001-fixes-some-not-all-buffer-overreads-during-decoding-.patch
deleted file mode 100644 (file)
index c98ed74..0000000
+++ /dev/null
@@ -1,65 +0,0 @@
-From 41bd04234b104312f54d25822f68738ba8d7133d Mon Sep 17 00:00:00 2001
-From: Marcus Meissner <marcus@jet.franken.de>
-Date: Tue, 25 Jul 2017 23:44:44 +0200
-Subject: [PATCH] fixes some (not all) buffer overreads during decoding pentax
- makernote entries.
-
-This should fix:
-https://sourceforge.net/p/libexif/bugs/125/ CVE-2016-6328
-
-Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
----
- libexif/pentax/mnote-pentax-entry.c | 16 +++++++++++++---
- 1 file changed, 13 insertions(+), 3 deletions(-)
-
-diff --git a/libexif/pentax/mnote-pentax-entry.c b/libexif/pentax/mnote-pentax-entry.c
-index d03d159..ea0429a 100644
---- a/libexif/pentax/mnote-pentax-entry.c
-+++ b/libexif/pentax/mnote-pentax-entry.c
-@@ -425,24 +425,34 @@ mnote_pentax_entry_get_value (MnotePentaxEntry *entry,
-               case EXIF_FORMAT_SHORT:
-                 {
-                       const unsigned char *data = entry->data;
--                      size_t k, len = strlen(val);
-+                      size_t k, len = strlen(val), sizeleft;
-+
-+                      sizeleft = entry->size;
-                       for(k=0; k<entry->components; k++) {
-+                              if (sizeleft < 2)
-+                                      break;
-                               vs = exif_get_short (data, entry->order);
-                               snprintf (val+len, maxlen-len, "%i ", vs);
-                               len = strlen(val);
-                               data += 2;
-+                              sizeleft -= 2;
-                       }
-                 }
-                 break;
-               case EXIF_FORMAT_LONG:
-                 {
-                       const unsigned char *data = entry->data;
--                      size_t k, len = strlen(val);
-+                      size_t k, len = strlen(val), sizeleft;
-+
-+                      sizeleft = entry->size;
-                       for(k=0; k<entry->components; k++) {
-+                              if (sizeleft < 4)
-+                                      break;
-                               vl = exif_get_long (data, entry->order);
-                               snprintf (val+len, maxlen-len, "%li", (long int) vl);
-                               len = strlen(val);
-                               data += 4;
-+                              sizeleft -= 4;
-                       }
-                 }
-                 break;
-@@ -455,5 +465,5 @@ mnote_pentax_entry_get_value (MnotePentaxEntry *entry,
-               break;
-       }
--      return (val);
-+      return val;
- }
--- 
-2.20.1
-
diff --git a/package/libexif/0002-On-saving-makernotes-make-sure-the-makernote-contain.patch b/package/libexif/0002-On-saving-makernotes-make-sure-the-makernote-contain.patch
deleted file mode 100644 (file)
index 84c9259..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-From c39acd1692023b26290778a02a9232c873f9d71a Mon Sep 17 00:00:00 2001
-From: Marcus Meissner <marcus@jet.franken.de>
-Date: Tue, 25 Jul 2017 23:38:56 +0200
-Subject: [PATCH] On saving makernotes, make sure the makernote container tags
- has a type with 1 byte components.
-
-Fixes (at least):
-       https://sourceforge.net/p/libexif/bugs/130
-       https://sourceforge.net/p/libexif/bugs/129
-
-CVE-2017-7544: libexif through 0.6.21 is vulnerable to out-of-bounds heap
-read vulnerability in exif_data_save_data_entry function in
-libexif/exif-data.c caused by improper length computation of the allocated
-data of an ExifMnote entry which can cause denial-of-service or possibly
-information disclosure.
-
-Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
----
- libexif/exif-data.c | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/libexif/exif-data.c b/libexif/exif-data.c
-index 67df4db..91f4c33 100644
---- a/libexif/exif-data.c
-+++ b/libexif/exif-data.c
-@@ -255,6 +255,12 @@ exif_data_save_data_entry (ExifData *data, ExifEntry *e,
-                       exif_mnote_data_set_offset (data->priv->md, *ds - 6);
-                       exif_mnote_data_save (data->priv->md, &e->data, &e->size);
-                       e->components = e->size;
-+                      if (exif_format_get_size (e->format) != 1) {
-+                              /* e->format is taken from input code,
-+                               * but we need to make sure it is a 1 byte
-+                               * entity due to the multiplication below. */
-+                              e->format = EXIF_FORMAT_UNDEFINED;
-+                      }
-               }
-       }
--- 
-2.20.1
-
diff --git a/package/libexif/0003-Reduce-maximum-recursion-depth-in-exif_data_load_dat.patch b/package/libexif/0003-Reduce-maximum-recursion-depth-in-exif_data_load_dat.patch
deleted file mode 100644 (file)
index e662d6b..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-From 5d28011c40ec86cf52cffad541093d37c263898a Mon Sep 17 00:00:00 2001
-From: Dan Fandrich <dan@coneharvesters.com>
-Date: Fri, 20 Apr 2018 18:05:19 +0200
-Subject: [PATCH] Reduce maximum recursion depth in exif_data_load_data_content
-
-This only needs to be a small, single digit integer for normal files,
-and reducing the maximum closer to this reduces the time and space
-needed to detect pathological cases.
-
-Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
----
- libexif/exif-data.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/libexif/exif-data.c b/libexif/exif-data.c
-index 91f4c33..04cdda2 100644
---- a/libexif/exif-data.c
-+++ b/libexif/exif-data.c
-@@ -378,7 +378,7 @@ exif_data_load_data_content (ExifData *data, ExifIfd ifd,
-       if ((((int)ifd) < 0) || ( ((int)ifd) >= EXIF_IFD_COUNT))
-         return;
--      if (recursion_depth > 30) {
-+      if (recursion_depth > 12) {
-               exif_log (data->priv->log, EXIF_LOG_CODE_CORRUPT_DATA, "ExifData",
-                         "Deep recursion detected!");
-               return;
--- 
-2.20.1
-
diff --git a/package/libexif/0004-Improve-deep-recursion-detection-in-exif_data_load_d.patch b/package/libexif/0004-Improve-deep-recursion-detection-in-exif_data_load_d.patch
deleted file mode 100644 (file)
index ff99154..0000000
+++ /dev/null
@@ -1,120 +0,0 @@
-From 6aa11df549114ebda520dde4cdaea2f9357b2c89 Mon Sep 17 00:00:00 2001
-From: Dan Fandrich <dan@coneharvesters.com>
-Date: Fri, 12 Oct 2018 16:01:45 +0200
-Subject: [PATCH] Improve deep recursion detection in
- exif_data_load_data_content.
-
-The existing detection was still vulnerable to pathological cases
-causing DoS by wasting CPU. The new algorithm takes the number of tags
-into account to make it harder to abuse by cases using shallow recursion
-but with a very large number of tags.  This improves on commit 5d28011c
-which wasn't sufficient to counter this kind of case.
-
-The limitation in the previous fix was discovered by Laurent Delosieres,
-Secunia Research at Flexera (Secunia Advisory SA84652) and is assigned
-the identifier CVE-2018-20030.
-
-[Peter: drop NEWS change]
-Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
----
- libexif/exif-data.c | 45 +++++++++++++++++++++++++++++++++++++--------
- 1 file changed, 37 insertions(+), 8 deletions(-)
-
-diff --git a/libexif/exif-data.c b/libexif/exif-data.c
-index e35403d..a6f9c94 100644
---- a/libexif/exif-data.c
-+++ b/libexif/exif-data.c
-@@ -35,6 +35,7 @@
- #include <libexif/olympus/exif-mnote-data-olympus.h>
- #include <libexif/pentax/exif-mnote-data-pentax.h>
-+#include <math.h>
- #include <stdlib.h>
- #include <stdio.h>
- #include <string.h>
-@@ -350,6 +351,20 @@ if (data->ifd[(i)]->count) {                              \
-       break;                                          \
- }
-+/*! Calculate the recursion cost added by one level of IFD loading.
-+ *
-+ * The work performed is related to the cost in the exponential relation
-+ *   work=1.1**cost
-+ */
-+static unsigned int
-+level_cost(unsigned int n)
-+{
-+    static const double log_1_1 = 0.09531017980432493;
-+
-+      /* Adding 0.1 protects against the case where n==1 */
-+      return ceil(log(n + 0.1)/log_1_1);
-+}
-+
- /*! Load data for an IFD.
-  *
-  * \param[in,out] data #ExifData
-@@ -357,13 +372,13 @@ if (data->ifd[(i)]->count) {                             \
-  * \param[in] d pointer to buffer containing raw IFD data
-  * \param[in] ds size of raw data in buffer at \c d
-  * \param[in] offset offset into buffer at \c d at which IFD starts
-- * \param[in] recursion_depth number of times this function has been
-- * recursively called without returning
-+ * \param[in] recursion_cost factor indicating how expensive this recursive
-+ * call could be
-  */
- static void
- exif_data_load_data_content (ExifData *data, ExifIfd ifd,
-                            const unsigned char *d,
--                           unsigned int ds, unsigned int offset, unsigned int recursion_depth)
-+                           unsigned int ds, unsigned int offset, unsigned int recursion_cost)
- {
-       ExifLong o, thumbnail_offset = 0, thumbnail_length = 0;
-       ExifShort n;
-@@ -378,9 +393,20 @@ exif_data_load_data_content (ExifData *data, ExifIfd ifd,
-       if ((((int)ifd) < 0) || ( ((int)ifd) >= EXIF_IFD_COUNT))
-         return;
--      if (recursion_depth > 12) {
-+      if (recursion_cost > 170) {
-+              /*
-+               * recursion_cost is a logarithmic-scale indicator of how expensive this
-+               * recursive call might end up being. It is an indicator of the depth of
-+               * recursion as well as the potential for worst-case future recursive
-+               * calls. Since it's difficult to tell ahead of time how often recursion
-+               * will occur, this assumes the worst by assuming every tag could end up
-+               * causing recursion.
-+               * The value of 170 was chosen to limit typical EXIF structures to a
-+               * recursive depth of about 6, but pathological ones (those with very
-+               * many tags) to only 2.
-+               */
-               exif_log (data->priv->log, EXIF_LOG_CODE_CORRUPT_DATA, "ExifData",
--                        "Deep recursion detected!");
-+                        "Deep/expensive recursion detected!");
-               return;
-       }
-@@ -422,15 +448,18 @@ exif_data_load_data_content (ExifData *data, ExifIfd ifd,
-                       switch (tag) {
-                       case EXIF_TAG_EXIF_IFD_POINTER:
-                               CHECK_REC (EXIF_IFD_EXIF);
--                              exif_data_load_data_content (data, EXIF_IFD_EXIF, d, ds, o, recursion_depth + 1);
-+                              exif_data_load_data_content (data, EXIF_IFD_EXIF, d, ds, o,
-+                                      recursion_cost + level_cost(n));
-                               break;
-                       case EXIF_TAG_GPS_INFO_IFD_POINTER:
-                               CHECK_REC (EXIF_IFD_GPS);
--                              exif_data_load_data_content (data, EXIF_IFD_GPS, d, ds, o, recursion_depth + 1);
-+                              exif_data_load_data_content (data, EXIF_IFD_GPS, d, ds, o,
-+                                      recursion_cost + level_cost(n));
-                               break;
-                       case EXIF_TAG_INTEROPERABILITY_IFD_POINTER:
-                               CHECK_REC (EXIF_IFD_INTEROPERABILITY);
--                              exif_data_load_data_content (data, EXIF_IFD_INTEROPERABILITY, d, ds, o, recursion_depth + 1);
-+                              exif_data_load_data_content (data, EXIF_IFD_INTEROPERABILITY, d, ds, o,
-+                                      recursion_cost + level_cost(n));
-                               break;
-                       case EXIF_TAG_JPEG_INTERCHANGE_FORMAT:
-                               thumbnail_offset = o;
--- 
-2.20.1
-
diff --git a/package/libexif/0005-fix-CVE-2019-9278.patch b/package/libexif/0005-fix-CVE-2019-9278.patch
deleted file mode 100644 (file)
index f708b2a..0000000
+++ /dev/null
@@ -1,90 +0,0 @@
-From 75aa73267fdb1e0ebfbc00369e7312bac43d0566 Mon Sep 17 00:00:00 2001
-From: Marcus Meissner <meissner@suse.de>
-Date: Sat, 18 Jan 2020 09:29:42 +0100
-Subject: [PATCH] fix CVE-2019-9278
-
-avoid the use of unsafe integer overflow checking constructs (unsigned integer operations cannot overflow, so "u1 + u2 > u1" can be optimized away)
-
-check for the actual sizes, which should also handle the overflows
-document other places google patched, but do not seem relevant due to other restrictions
-
-fixes https://github.com/libexif/libexif/issues/26
-
-Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
----
- libexif/exif-data.c | 28 ++++++++++++++++++----------
- 1 file changed, 18 insertions(+), 10 deletions(-)
-
-diff --git a/libexif/exif-data.c b/libexif/exif-data.c
-index a6f9c94..6332cd1 100644
---- a/libexif/exif-data.c
-+++ b/libexif/exif-data.c
-@@ -192,9 +192,15 @@ exif_data_load_data_entry (ExifData *data, ExifEntry *entry,
-               doff = offset + 8;
-       /* Sanity checks */
--      if ((doff + s < doff) || (doff + s < s) || (doff + s > size)) {
-+      if (doff >= size) {
-               exif_log (data->priv->log, EXIF_LOG_CODE_DEBUG, "ExifData",
--                                "Tag data past end of buffer (%u > %u)", doff+s, size);       
-+                                "Tag starts past end of buffer (%u > %u)", doff, size);
-+              return 0;
-+      }
-+
-+      if (s > size - doff) {
-+              exif_log (data->priv->log, EXIF_LOG_CODE_DEBUG, "ExifData",
-+                                "Tag data goes past end of buffer (%u > %u)", doff+s, size);
-               return 0;
-       }
-@@ -315,13 +321,14 @@ exif_data_load_data_thumbnail (ExifData *data, const unsigned char *d,
-                              unsigned int ds, ExifLong o, ExifLong s)
- {
-       /* Sanity checks */
--      if ((o + s < o) || (o + s < s) || (o + s > ds) || (o > ds)) {
--              exif_log (data->priv->log, EXIF_LOG_CODE_DEBUG, "ExifData",
--                        "Bogus thumbnail offset (%u) or size (%u).",
--                        o, s);
-+      if (o >= ds) {
-+              exif_log (data->priv->log, EXIF_LOG_CODE_DEBUG, "ExifData", "Bogus thumbnail offset (%u).", o);
-+              return;
-+      }
-+      if (s > ds - o) {
-+              exif_log (data->priv->log, EXIF_LOG_CODE_DEBUG, "ExifData", "Bogus thumbnail size (%u), max would be %u.", s, ds-o);
-               return;
-       }
--
-       if (data->data) 
-               exif_mem_free (data->priv->mem, data->data);
-       if (!(data->data = exif_data_alloc (data, s))) {
-@@ -947,7 +954,7 @@ exif_data_load_data (ExifData *data, const unsigned char *d_orig,
-       exif_log (data->priv->log, EXIF_LOG_CODE_DEBUG, "ExifData", 
-                 "IFD 0 at %i.", (int) offset);
--      /* Sanity check the offset, being careful about overflow */
-+      /* ds is restricted to 16 bit above, so offset is restricted too, and offset+8 should not overflow. */
-       if (offset > ds || offset + 6 + 2 > ds)
-               return;
-@@ -956,6 +963,7 @@ exif_data_load_data (ExifData *data, const unsigned char *d_orig,
-       /* IFD 1 offset */
-       n = exif_get_short (d + 6 + offset, data->priv->order);
-+      /* offset < 2<<16, n is 16 bit at most, so this op will not overflow */
-       if (offset + 6 + 2 + 12 * n + 4 > ds)
-               return;
-@@ -964,8 +972,8 @@ exif_data_load_data (ExifData *data, const unsigned char *d_orig,
-               exif_log (data->priv->log, EXIF_LOG_CODE_DEBUG, "ExifData",
-                         "IFD 1 at %i.", (int) offset);
--              /* Sanity check. */
--              if (offset > ds || offset + 6 > ds) {
-+              /* Sanity check. ds is ensured to be above 6 above, offset is 16bit */
-+              if (offset > ds - 6) {
-                       exif_log (data->priv->log, EXIF_LOG_CODE_CORRUPT_DATA,
-                                 "ExifData", "Bogus offset of IFD1.");
-               } else {
--- 
-2.20.1
-
index 8a38b477b8dcaf85dcbe09ed96a5dea9259fa628..8064c2e9f9caa98cde428efe608fc38bf2b836e6 100644 (file)
@@ -6,4 +6,4 @@ config BR2_PACKAGE_LIBEXIF
          image. The EXIF library allows you to parse an EXIF file
          and read the data from those tags.
 
-         http://libexif.sf.net
+         https://libexif.github.io
index aa9fcc8d89ce64a524ea9501ebeb0b545e19ae8b..1a2157b3f585bf436ba0e3cafbcc639ef412d17b 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed:
-sha256  16cdaeb62eb3e6dfab2435f7d7bccd2f37438d21c5218ec4e58efa9157d4d41a  libexif-0.6.21.tar.bz2
+sha256  5048f1c8fc509cc636c2f97f4b40c293338b6041a5652082d5ee2cf54b530c56  libexif-0.6.22.tar.xz
 sha256  36b6d3fa47916943fd5fec313c584784946047ec1337a78b440e5992cb595f89  COPYING
index 643d9ed89326a7c14975c0deb00e4412d079bcf7..c945c275a7061670c2eabc6fdca9c9ecb635753f 100644 (file)
@@ -4,21 +4,13 @@
 #
 ################################################################################
 
-LIBEXIF_VERSION = 0.6.21
-LIBEXIF_SOURCE = libexif-$(LIBEXIF_VERSION).tar.bz2
-LIBEXIF_SITE = http://downloads.sourceforge.net/project/libexif/libexif/$(LIBEXIF_VERSION)
+LIBEXIF_VERSION = 0.6.22
+LIBEXIF_SOURCE = libexif-$(LIBEXIF_VERSION).tar.xz
+LIBEXIF_SITE = \
+       https://github.com/libexif/libexif/releases/download/libexif-$(subst .,_,$(LIBEXIF_VERSION))-release
 LIBEXIF_INSTALL_STAGING = YES
 LIBEXIF_DEPENDENCIES = host-pkgconf
 LIBEXIF_LICENSE = LGPL-2.1+
 LIBEXIF_LICENSE_FILES = COPYING
 
-# 0001-fixes-some-not-all-buffer-overreads-during-decoding-.patch
-LIBEXIF_IGNORE_CVES += CVE-2016-6328
-# 0002-On-saving-makernotes-make-sure-the-makernote-contain.patch
-LIBEXIF_IGNORE_CVES += CVE-2017-7544
-# 0004-Improve-deep-recursion-detection-in-exif_data_load_d.patch
-LIBEXIF_IGNORE_CVES += CVE-2018-20030
-# 0005-fix-CVE-2019-9278.patch
-LIBEXIF_IGNORE_CVES += CVE-2019-9278
-
 $(eval $(autotools-package))