qt5: base infrastructure
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 7 Mar 2013 10:18:36 +0000 (10:18 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 10 Mar 2013 21:36:32 +0000 (22:36 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt5/Config.in [new file with mode: 0644]
package/qt5/qt5.mk [new file with mode: 0644]

diff --git a/package/qt5/Config.in b/package/qt5/Config.in
new file mode 100644 (file)
index 0000000..0acb89e
--- /dev/null
@@ -0,0 +1,18 @@
+comment "Qt5 needs a toolchain with WCHAR, IPv6, thread and C++ support"
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || !BR2_INET_IPV6 || !BR2_TOOLCHAIN_HAS_THREADS
+
+menuconfig BR2_PACKAGE_QT5
+       bool "Qt5"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_USE_WCHAR
+       depends on BR2_INET_IPV6
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       help
+         This option enables the Qt5 framework. Sub-options allow to
+         select which modules should be built.
+
+         http://qt-project.org
+
+if BR2_PACKAGE_QT5
+
+endif
diff --git a/package/qt5/qt5.mk b/package/qt5/qt5.mk
new file mode 100644 (file)
index 0000000..8b1a7ed
--- /dev/null
@@ -0,0 +1 @@
+include package/qt5/*/*.mk